1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

VI no mac os x

Discussão em 'Apple Geral' iniciada por lickyyy, 27 de Fevereiro de 2007. (Respostas: 14; Visualizações: 1080)

  1. lickyyy

    lickyyy Power Member

    Alguem sabe como ponho o vi do mac os x (o do terminal), com suporte para acentos e outras caracteres?
     
  2. jck

    jck Power Member

    Não te sei responder a essa pergunta, mas já agora se puderem dizer que editor de texto usam para programar no mac agradeço.
     
  3. lickyyy

    lickyyy Power Member

    jck s fosse d cs ja tinhas respondido...
     
  4. ajax

    ajax Banido

    Deve haver um problema qq com a configuração. Eu uso o vi e tenho acentos.
     
  5. Rui_Carlos

    Rui_Carlos 1st Folding then Sex

    penso que o problema não é do Vi mas sim do Terminal.
    vai a "Windows Settings..." e na parte de "Display" experimenta alterar o "Character Set Encoding" (eu tenho "Western (ISO Latin 1)"), penso que foi assim que resolvi o problema, mas já não me lembro ao certo.
     
  6. ajax

    ajax Banido

    Acho isso esquisito porque o default deve ser o Unicode UTF-8 que é o que eu uso e é o que é aconselhado daqui para a frente.
     
  7. Rui_Carlos

    Rui_Carlos 1st Folding then Sex

    eu com UTF-8 quando meto um acento fico com um espaço a seguir ao caracter que ficou com o assento. além disso, os ficheiros que já tinha (criados em Linux) apareciam-me com '?' em vez dos caracteres acentuados.

    eu sei que resolvi este problema nas "Windows Settings", mas já não sei o que é que fiz exactamente...
     
  8. lickyyy

    lickyyy Power Member

    era isso, pus em Ocidental Latino-1 e ja funca :) . thx

    ja agora alguem sabe cm por a syntax a ligar s automaticamente? pq tenho d fazer smp syntax on.... nao custa nada mas pronto :)
     
  9. Rui_Carlos

    Rui_Carlos 1st Folding then Sex

    uma possível solução é colocar a linha 'syntax enable' no ficheiro '.vimrc'.
     
  10. ajax

    ajax Banido

    ainda sobre o encoding não esqueçam que há outro factor em jogo que é o "Keyboard" escolhido como "Input Source". Eu uso um keyboard layout em unicode por causa das tosses.
     
  11. Rui_Carlos

    Rui_Carlos 1st Folding then Sex

    ajax, consegues por acentos no Terminal?
    é que no Vi já resolvi o problema, mas no terminal quando tento usar acentos aparece-me um '\' e número.
     
  12. ajax

    ajax Banido

    Isso não mas também não é aconselhável. ;)

    nomes de ficheiros com caracteres acentuados que dependem fortemente do encoding usado não é bom. :D

    Mas se quiseres aventurar-te e uma vez que não tenho lá muito tempo (a hora do almoço está a esgotar-se) fica aqui um link que encontrei agora mesmo que te ajuda certamente.

    http://www.rift.dk/news.php?item.7.6

    Creio que também podes usar o fink caso queiras instalar uma nova versão da bash. Vai na versão 3.0-2.
     
    Última edição: 28 de Fevereiro de 2007
  13. lickyyy

    lickyyy Power Member

    Oh Sr Rui Carlos o problema e k eu nao sei fazer isso no vimrc :(
     
  14. Rui_Carlos

    Rui_Carlos 1st Folding then Sex

    verifica se tens ficheiro com o nome '.vimrc' na tua home.
    se o tiveres, edita-o e acrescenta a linha que te indiquei.
    caso contrário, ou crias e pões lá simplesmente essa linha, ou copias o ficheiro 'vimrc_example.vim' (no meu caso esse ficheiro está em '/usr/share/vim/vim70') para a tua home, mudas o nome para '.vimrc' e adicionas a linha que referi.
     
    Última edição: 28 de Fevereiro de 2007
  15. Rui_Carlos

    Rui_Carlos 1st Folding then Sex

    muito obrigado!!
    já resolvi o problema do acentos e acabei também por conseguir por a tecla 'Del' a funcionar...
     

Partilhar esta Página