1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Videos (.avi) no ubuntu

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por d3baser, 28 de Outubro de 2007. (Respostas: 15; Visualizações: 5662)

  1. d3baser

    d3baser Power Member

    Alguém me pode dizer como é que eu faço para ver videos no ubuntu (gutsy)? Já instalei o xine, mplayer, uma cena chamada win32, ffmpeg, ubuntu restricted extras... E não consigo por isto a ler videos em nenhum player :\
     
  2. ruimoura

    ruimoura Power Member

    Basta instalar o mplayer e dá para quase tudo ... Há aí qq coisa que não bate certo.
     
  3. d3baser

    d3baser Power Member

    No mplayer o erro que dá é: "error opening/initializing the selected video_out (-vo) device".

    Mas dá erro em qualquer programa, só varia o erro.
     
  4. neonl

    neonl Banido

    Boas.

    Isso não é problema de codecs. Esse erro é... Precisamente isso, tens o formato de rendering de imagem errado para o teu hardware. Agora não me lembro qual é o apropriado, mas se fores às settings do mplayer é... tentativa e erro (para alterar as settings é preciso reiniciar o programa).

    Se não queres ter esse trabalho (às vezes não fica o melhor), usa o VLC - é universal e no geral não dá problemas. Instalar o VLC com o APT a partir de repositórios:
    Código:
    Activar todos os repos. utilizando o servidor internacional (não usar o português, às vezes não funciona).
    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get install vlc vlc-plugin-esd mozilla-plugin-vlc
    Cumps
     
  5. JKL22

    JKL22 Power Member

    Vais às preferências do MPlayer > Video > Drivers e seleccionas: "x11".
     
  6. neonl

    neonl Banido

    Esse não é o que tem melhor qualidade de vídeo necessariamente. É preferível usar o VLC (na minha opinião).
     
  7. d3baser

    d3baser Power Member

    No VLC ele diz que não reconhece o video. "Unrecognized format for '/home/joao/Desktop/HouseS04E04.avi'"

    Ao mudar os driver para o x11, o mplayer mete a janela do video no tamanho do video, mas tanto essa janela como a janela mais pequena dos controlas ficam pretas e o programa fecha-se sozinho :\
     
  8. JKL22

    JKL22 Power Member

    Se o VLC pusesse as legendas nos filmes decentemente...
     
  9. neonl

    neonl Banido

    Pois. Lol. Isso é verdade. Eu quando preciso de legendas uso, de facto, o mplayer mas acho que uso um qualquer com openGL mas não funcionava com a minha gráfica antiga (ATI x600).
     
  10. hellaxe

    hellaxe Power Member

    O correcto deve ser
    Código:
    x11/xv.
    experimenta lá.
     
  11. ruimoura

    ruimoura Power Member

    Já dei essa dica aqui uns 10 milhões de vezes, mas as pessoas estão sempre a perguntar o mesmo. X11. Ponto final.
     
  12. astrisko

    astrisko 1st Folding then Sex

    E coloca não ficam tão eyecandy como no Mplayer, mas podem ficar bastante decentes.

    São precisos 2 passos

    1º -> Mudar a codificação de UTF8 para ISO-8859-1. Preferences -> Input/codecs -> Other codecs -> subtitles. Este passo resolve o problema de não aparecerem todas as legendas, o 2º passo é só mesmo para as colocar mais bonitas.

    2º -> Preferences -> Video -> Subtitles/OSD -> Text renderer e depois é ir experimentando até o resultado agradar.
     
  13. rikhard.fsoss

    rikhard.fsoss Banido


    que placa gráfica tens? está com aceleração? é nvidia?

    se fôr nvidia e estiver com aceleração, drivers fechados da nvidia, coloca no mplayer config xv.

    podes experimentar primeiro:

    $mplayer -vo xv *.avi

    para veres quais os modos que o mplayer está a suportar faz:

    $mplayer -vo help

    eu gosto imenso do frontend para mplayer que é o SMPlayer, é excelente, puxa o deb em get-deb.org

    cumps,
     
  14. d3baser

    d3baser Power Member

    Essa era a que estava :\

    A minha placa gráfica é uma onboard, da intel... Não sei ao certo qual é, mas acho que o chipset é o 915.
    Não sei se tenho aceleração...

    O outpur com o primeiro comando é este:
    Código:
    CPU: Intel(R) Celeron(R) M processor         1.60GHz (Family: 6, Model: 13, Stepping: 8)
    CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled with runtime CPU detection.
    Can't open joystick device /dev/input/js0: No such file or directory
    Can't init input joystick
    mplayer: could not connect to socket
    mplayer: No such file or directory
    Failed to open LIRC support. You will not be able to use your remote control.
    
    Playing *.avi.
    File not found: '*.avi'
    Failed to open *.avi.
    
    
    Exiting... (End of file)
    
    edit: eu antes de formatar o pc (também tinha ubuntu) via filmes na boa... Mas não estou com muita vontade de formatar outra vez só por causa disto lol
     
    Última edição: 28 de Outubro de 2007
  15. lothar_m

    lothar_m Power Member


    muito obrigado pela informação. funcionou perfeitamente!
     
  16. hellaxe

    hellaxe Power Member

    É impressão minha ou o output diz que não encontra o mplayer?
     

Partilhar esta Página