1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.
  2. A secção Microsoft/Windows encontra-se actualmente em processo de reestruturação.
    Remover anúncio

Vista: "Your profile was not loaded correctly."

Discussão em 'Windows 7 e anteriores' iniciada por redshot, 13 de Julho de 2008. (Respostas: 16; Visualizações: 895)

  1. redshot

    redshot Electromoderator
    Staff Member

    Boas. Andei a experimentar um disco velho no meu computador, e quando voltei a ligar o normal, "NTLDR is missing". Corri o DVD do Vista, reparei o arranque, e entrou-me no Vista.

    Só que eu tinha o XP em dual boot, e agora não lhe consigo aceder. Já arranquei com o CD do XP e fiz o fixboot, mas aparece outra vez o "NTLDR is missing", e não sei porquê, pois a partição do XP é a que contém o sector de arranque (portanto, a que aparece em primeiro lugar) e devia correr sozinha, sem o Vista a atrapalhar.

    Como é que eu corrijo isto?

    EDIT: Update em baixo.
     
    Última edição: 16 de Julho de 2008
  2. azzancha

    azzancha Power Member

    não tens nenhuma disquete inserida ?
     
  3. redshot

    redshot Electromoderator
    Staff Member

    Não. A única disquete que inseri foi para carregar os drivers sata para o XP. Mas na BIOS não tenho a disquete no arranque.
     
  4. kimp

    kimp Power Member

  5. redshot

    redshot Electromoderator
    Staff Member

    Esses ficheiros já lá estão, eu queria era inserir o XP no arranque. No XP era fácil, estava tudo no ficheiro boot.ini, mas agora no Vista não sei onde está.
     
  6. kimp

    kimp Power Member

    No Vista é diferente e mais complicado. Podes instalar o vistabootpro, como ja disse, que faz o trabalho todo e no final até o podes desinstalar, ou entao podes editar o bcdedit seguindo este tutorial.

    Cmpts
     
  7. redshot

    redshot Electromoderator
    Staff Member

    Já sei qual é O problema. É que eu tenho dois discos: um IDE e um SATA, e a motherboard reconhece como boot o IDE. Na consola de reparação do XP, quando eu digito "C:" e "dir", aparece-me esse disco IDE que não tem nenhum sistema operativo instalado.

    Fiz a cópia do NTLDR e agora aparece "NTLDR is compressed".

    EDIT: Já defini na bios o sata para disco de boot. Vamos ver como se comporta.

    EDIT2: Dá igual. Se calhar porque também mexi no NTLDR original. Amanhã vou fazer outro fixmbr e fixboot (com o cd do XP), e depois digo alguma coisa.
     
    Última edição: 14 de Julho de 2008
  8. kimp

    kimp Power Member

    Tenta isso
     
  9. redshot

    redshot Electromoderator
    Staff Member

    Mas tento isso em que partição? Naquela em que o XP está instalado ou na do disco IDE? É que a partição C é esse mesmo disco.

    EDIT: Tentei em ambas e continua: "NTLDR is compressed".
     
    Última edição: 14 de Julho de 2008
  10. kimp

    kimp Power Member

  11. redshot

    redshot Electromoderator
    Staff Member

    Agora o XP aparece como único sistema operativo, e mesmo assim não arranca, empanca ao iniciar (um problema que eu resolvo mais tarde:p). O que acontece é que ao meter o DVD do Vista para restaurar o arranque do Vista, não aparece o do XP, e quando reinicio outra vez, o boot do Vista desaparece, e fica só o do XP. WTF? Já estou um bocado farto disto, e se calhar vou formatar.
     
  12. redshot

    redshot Electromoderator
    Staff Member

  13. kimp

    kimp Power Member

    MAs chegaste a instalar o vista boot ou não? ou a fazer aquilo que dizia no tutorial?
     
  14. redshot

    redshot Electromoderator
    Staff Member

    Sim, utilizei o Vistaboot, e adicionei o XP ao arranque, fazendo corresponder à partição respectiva. Agora parece que o problema é do boot.ini, e depois não encontra o ficheiro hal.dll, mas confirmei que ele está lá. Será que a partição que o vista reconhece como D tem outra letra quando no arranque?
     
  15. kimp

    kimp Power Member

    Nao me aparece.
    Neste momento a situação está como?
    Tens os 2 SO's no menu do boot?
    Entres perfeitamente no vista mas no XP é que dá esse erro certo?
    Como fizeste no vista boot pro? Julgo que só tinhas de indicar kal o disco que tinha o windows xp e guardar.

    O hal.dll pod estar corrompido, substitui pelo do cd do xp ou saca da net.

    Cmps
     
  16. redshot

    redshot Electromoderator
    Staff Member

    Boas, já consegui. Já sei porque é que ele não dava: os ficheiros de arranque não estavam na partição C: onde estava instalado o XP, mas estavam no disco IDE de dados. Este estava definido para Master e o que contém os sistemas operativos para slave.

    Ao que parece os ficheiros de arranque no disco IDE estavam ou corrompidos, ou mal configurados; foi só tirar-lhe o jumper e metê-lo no SATA. Tá resolvido.

    Obrigado na mesma pelas respostas.:x2:
     
  17. redshot

    redshot Electromoderator
    Staff Member

    Outro problema??

    Resolvo um problema e aparece-me logo outro. Por determinadas razões, tive de fazer (mais uma vez) a recuperação do arranque do Vista. Ele identificou-me logo o problema mo arranque, e pediu para corrijir. Eu acedi, e deixei-o fazer as correcções.

    Mas, quando reiniciei, ele entrou no Vista, e depois em vez de aparecer o habitual "Welcome", aparece "Preparing your Desktop".

    Resumindo: ele criou uma conta temporária onde eu não posso fazer absolutamente nada, e depois aparece um pop-up a dizer: "Your profile was not loaded correctly. You have been logged in with a temporary profile..." etc etc. Ou seja, ele n\ao reconhece o utilizador que lá está.

    Já pesquisei na internet sobre este problema, e há uma solução, que implica apagar uma chave no registo. Não funcionou. E agora?
     

Partilhar esta Página