1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.
  2. COVID-19 Mantenham-se seguros: Pratiquem distanciamento físico de 2 metros. Lavem as mãos. Usem máscara.
    Informação sobre COVID-19. Ajuda a combater o COVID-19 com o [email protected] e com o [email protected].
    Remover anúncio

Problemas Técnicos VPN - L2TP over IPSEC

Discussão em 'Suporte e Artigos—Internet, Redes, Segurança' iniciada por bomb, 22 de Março de 2020. (Respostas: 13; Visualizações: 452)

  1. bomb

    bomb I quit My Job for Folding

    Boas pessoal,
    Espero que me possa ajudar, estou a tentar implementar uma vpn num router draytek a passar primeiro por um router cisco mas infelizmente nao estou a conseguir.
    Coloco aqui a duvida completa que coloquei no forum da Cisco mas que infelizmente nao obtive resposta. Peco desculpa por estar em ingles

    Tenho o protocol 50 a ser reencaminhado para o router, e tenho as portas 500, 4500 e 1723 abertas no router da Cisco a serem reenchaminhas para a Wan do router Draytek
    A VPN em PPTP funciona correctamente mas em L2TP over IPSEC nao há forma de funcionar

    Alguem tem ideias do que eu possa estar a fazer mal??

    Obrigado desde já
     
  2. CrOhN

    CrOhN Suspenso

    Abriste em UDP? E a porta 1701?
     
  3. bomb

    bomb I quit My Job for Folding

    Como existem informacoes ambiguas na internet abri essa porta tanto em TCP como em UDP a apontar para o interface WAN do Draytek. O protocol 50 (ESP) esta aberto para o IP local do Draytek, 10.14.99.99.
    Em PPTP ele usa este protocolo e usa a porta 1723. E por aqui funciona, ja experimentei retirar a porta 1723 e deixo de ter acesso... nao consigo entender o porque de por L2TP nao conseguir ter acesso... no cisco tenho abertas as portas, 1701, 500, 4500 e 1723. E todas estas portas estao a apontar o interface wan do draytek
     
  4. CrOhN

    CrOhN Suspenso

    Não consegues fazer DMZ para o draytek? Se funcionar, despistavas se seria problema de portas.

    Mas estou em crer que poderá ser problema de estarem dentro de uma NAT.

    O draytek vai ser server, ou será cliente? É que ao contrário (Draytek dentro de NAT a ligar a outro directamente na internet) funciona. Já tive um assim dentro de uma NAT com um router 4G.

    Vê se te ajuda: https://forum.mikrotik.com/viewtopic.php?t=129801
     
  5. bomb

    bomb I quit My Job for Folding

    Para fazer DMZ usando a cli do router terei que fazer "n" configuracoes e terei que configurar uma access list e policies pelo que andei a ver. Queria tentar evitar isso... mas em ultimo caso terei que o fazer
    O draytek sera o server, e todos os clientes externos usaram o Draytek Smart VPN client para liagacao ao Draytek. A questao é, tenho a porta 1723 que e usada para pptp aberta e a vpn funciona neste modo. Abri as restantes portas da mesma forma que a 1723, condigurei a nat e apontei quando a porta 500 for pedida para apontar parano endereco wan do router, mas nao funciona... pelo que li pptp e l2tp over ipsec partilham o mesmo protocol 50 (esp) e este ja esta aberto na nat.
    Vou dar uma vista de olhos no topico
    Obrigado
     
  6. bomb

    bomb I quit My Job for Folding

    Vi agora o topico e eles dizem para fazer forward das portas e que devia funcionar. A ultima reply e duma pessoa que esta a ter o mesmo problema que eu, em pptp funciona mas nao em l2tp... mas infelizmente nao houve resposta a esse post
    Honestamente nao sei que fazer mais
     
  7. At Work

    At Work Power Member

    Desativa o túnel PPTP e configura só para IPSec L2TP e testa.

    Cumps
     
  8. bomb

    bomb I quit My Job for Folding

    Obrigado pelas respostas
    Executei isto mas continua a nao dar...
    Dessctivei o pptp e o mesmo se passa... o client fica preso na fase dial e nao sai dali
    Verifiquei atraves do Cisco usando o comando "show ip nat translations" e consigo ver o cliente a ligar-se as portas 500 e 4500 e o router a executar a nat correctamente e a redireccionar para o ip wan do Draytek, mas nao passa dai...
    Se fizer um port scan a porta 1723, porta usada pelo pptp diz que esta aberta, fiz o teste de remove da nat esta porta e automaticamente passa a fechada. Executei os mesmo comandos para abrir as outras portas mas fazendo um teste das portas a partir de fora diz que ambas estao fechadas... nao consigo entender
     
  9. At Work

    At Work Power Member

    Não tive oportunidade de analisar em mais detalhe o teu problema.

    Qual é a finalidade da VPN? Túnel Site to Site ou, VPN Users to Site?

    Cumps
     
  10. bomb

    bomb I quit My Job for Folding

    Boas,
    Basicamente é VPN users to site.
    O site está configurado da seguinte forma, um router Draytek conectado à LAN e as duas portas WAN deste router estão conectadas a dois routers cisco. Estes routers Cisco por sua vez estão conectados à Internet. Existem duas linhas porque o draytek està a fazer load balancing do tráfego, mas a VPN está a passar pelo Router da Cisco que se encontra conectado à WAN 1 do Draytek

    Obrigado
     
  11. bomb

    bomb I quit My Job for Folding

    Bem isto vai ser estranho, mas hoje tentei novamente ligar-me a VPN e sem qualquer alteracao que seja ou modificacao comecou outras a funcionar... nao consigo entender o porque
    Obrigado a todos pela ajuda
     
  12. At Work

    At Work Power Member

    Sendo que a finalidade do acesso VPN é para os users acederem à rede interna, configura SSL VPN no DrayTek. Têm cliente VPN para o efeito.

    Cumps
     
  13. Boas
    Por acaso sabes porque razão não estava a funcionar e depois passou a funcionar? Fizeste efetivamente alguma alteração que depois tivesses percebido?
    Eu estou com um problema muito semelhante. Já não sei o que fazer.
    Tenho a WAN1 de um Draytek ligado como servidor VPN á LAN do router HG8247Q do ISP. Não existe forma de fazer funcioanr a VPN L2TP apesar de funcionar em PPTP! Já experimentei com outro router Draytek noutro local com um ISP diferente e um router diferente e acontece exatamente o mesmo, ou seja funciona em PPTP e não funciona em IPSec L2TP!
    Alguém pode ajudar? Não entendo.
    Cumps