Windows 10: "X:" em vez de "C:"?!

kronnuz

Power Member
Olá pessoal.
Estive a desabilitar algumas funcionalidades do Windows 10 ara tentar tornar o PC mais leve (não mexi em nada que tivesse a ver com o registo), mas ao reiniciar a máquina pede-me para "escolher o layout do teclado".
Fazendo isso, então ele vai para a página de Troubleshoot/Desligar PC.

Não consigo sair desta secção porque não me permite reiniciar para uma data anterior, não me permite fazer uma restauração de fábrica porque diz que não encontra nenhuma imagem no disco...
Ao entrar no prompt de comando reparei que o C: foi substituído por X:...

Já tentei uma série de comandos, mas nada resultou...
Não consigo aceder ao modo de segurança...

O que sugerem?
Clean install e siga para bingo?

Obrigado
 

Genjuro

Power Member
Quando inicias a linha de comandos pela recuperação é normal ele atribuir o X: á drive.

Não sei o que já testaste, mas tens várias hipóteses:

- Na linha de comandos tentar fazer o rebuild do BCD:

https://support.microsoft.com/en-us...p-issues-902ebb04-daa3-4f90-579f-0fbf51f7dd5d

- Com uma pen USB com a instalação do Windows reparar o BCD (mesma coisa de cima).

- Usar o Rescatux/Super Grub Disk:

https://www.supergrubdisk.org

- Ligar o teu disco numa caixa externa USB ou num outro PC e ver se as partições do disco ainda existem e estão OK e aproveitar para copiares os teus dados.
 

kronnuz

Power Member
Ok, já consegui solucionar o problema... Acabei por optar por formatar.
Depois de alguns erros na instalação (não estava fácil!), lá consegui fazer uma instalação limpa do início ao fim.

Agora só me falta resolver uma coisa:
- tenho o SO instalado no disco SDD;
- tenho um HDD de 930Gb em que me aparede uma partição com cerca de 15Gb de espaço não alocado.
Nem mesmo aquando da formatação consigo remover essa partição (provavelmente quem instalou o Windows nesta máquina a primeira vez, terá criado aquela partição, não sei... O PC é de um amigo meu).

Não consigo fazer nada dela...
Nem pelo gestor de discos do Windows (entre a partição de 915Gb e a de 15Gb tenho uma de 100mb que é a partição EFI), portanto, parto do principio que nunca conseguiria alocar esse espaço pela ferramenta do Windows porque não está no espaço seguinte ao da de 915Gb.
Quando tento criar um novo volume, diz-me que não tenho espaço em disco suficiente para concluir a operação.

Já experimentei o mini tool wizard, o AOMEI e mais um programa de que não me recordo agora, mas não tive sucesso.
Ah! E esse tal espaço não alocado de 15Gb só me aparece no mini tool wizard.
Nem indo pelo command prompt - diskpart - list volume, ele aparece...

A partição de 915Gb está em formato dinâmico (não sei porquê, não seleccionei nada). Poderá ter a ver com isto?

Cumprimentos e obrigado!
 

MaNoFtHeGrAsS

Power Member
Ok, já consegui solucionar o problema... Acabei por optar por formatar.
Depois de alguns erros na instalação (não estava fácil!), lá consegui fazer uma instalação limpa do início ao fim.

Agora só me falta resolver uma coisa:
- tenho o SO instalado no disco SDD;
- tenho um HDD de 930Gb em que me aparede uma partição com cerca de 15Gb de espaço não alocado.
Nem mesmo aquando da formatação consigo remover essa partição (provavelmente quem instalou o Windows nesta máquina a primeira vez, terá criado aquela partição, não sei... O PC é de um amigo meu).

Não consigo fazer nada dela...
Nem pelo gestor de discos do Windows (entre a partição de 915Gb e a de 15Gb tenho uma de 100mb que é a partição EFI), portanto, parto do principio que nunca conseguiria alocar esse espaço pela ferramenta do Windows porque não está no espaço seguinte ao da de 915Gb.
Quando tento criar um novo volume, diz-me que não tenho espaço em disco suficiente para concluir a operação.

Já experimentei o mini tool wizard, o AOMEI e mais um programa de que não me recordo agora, mas não tive sucesso.
Ah! E esse tal espaço não alocado de 15Gb só me aparece no mini tool wizard.
Nem indo pelo command prompt - diskpart - list volume, ele aparece...

A partição de 915Gb está em formato dinâmico (não sei porquê, não seleccionei nada). Poderá ter a ver com isto?

Cumprimentos e obrigado!
em relaçao a nao conseguires fazer nada com o disco...

abre o cmd como admin, escreve diskpart -> enter
depois list disk (acho eu)
depois select disk # (# o numero do disco que queres seleccionar)
depois clean

a partir tens o disco sem partiçoes e sem sistema de ficheiros, só te resta.... melhor ainda! passa por aqui

Boa sorte
 

kronnuz

Power Member
em relaçao a nao conseguires fazer nada com o disco...

abre o cmd como admin, escreve diskpart -> enter
depois list disk (acho eu)
depois select disk # (# o numero do disco que queres seleccionar)
depois clean

a partir tens o disco sem partiçoes e sem sistema de ficheiros, só te resta.... melhor ainda! passa por aqui

Boa sorte
Já consegui!
Eliminei os volumes e depois converti o disco em básico.
Voltei a formatar e já me deixou apagar todas as partições (nem criei novo, deixei para depois fazer na ferramenta do Windows).
All done! Agora sim, está como queria :) obrigado!
 
Topo