Windows ME: porque o MS-DOS fica em ecra preto?

Cambalinho

Power Member
eu ja tentei várias versões do Spear of Destiny ou Wolf3d(são o mesmo jogo de MS-DOS) e em ambas a versões dão-me o mesmo efeito: ecra preto.
os outros jogos parecem rodar normalmente... eu instalei o DX9.c
parece estar tudo normal para rodar o jogo(os outros jogos de DOS, rodam normalmente), mas este deixa o ecra preto... como posso resolver este problema?
 

AntenaMan

Banido
Jogos em DOS não usam API's como o directx. O windows Me também não suporta boot em MS-Dos, mas é um OS da família 9.x. O spear of destiny não conheço, mas o wolf3d é um jogo nativo MS-DOS, não corre em Windows.

Experimenta isto, clique direito no excutável, propriedades e procura uma opção para carregar a aplicação em modo MS-DOS nativo, o que ele faz é sair do Windows carrega a aplicação em modo MS-DOS e depois quando sais da aplicação volta a carregar o Windows. O windows 98 suportava isto, como o Me é da mesma família talvez ainda suporte, mas não sei, nunca tive o Me instalado.
 
Última edição:

Cambalinho

Power Member
por isso estou a formatar o computador e instalar o windows 98.
espero conseguir, com o 'setup /p j', instalar o Windows e o computador desligar automaticamente.
 

Cambalinho

Power Member
entendi algumas coisas:
1 - se reiniciar em modo MS-DOS, o jogo demora, mas entra(mas sem o som de fundo, só os efeitos), por isso usa o speaker;
2 - será por causa do 'Gestor Dispositivos' só mostrar 1 unico driver de som, em vez de ter a emulação do Sound Blaster?
ainda estou a tentar entender o motivo do problema
 

Cambalinho

Power Member
Acer Aspire 1690
RAM: 512MB's
Graphics: Radeon X600 64MB's
CPU: Centrino 1.5GH'z
é para o Windows XP, mas instalei o Windows 98 e tive de usar o comando 'setup /p i' para poder instalar ou ao detectar os drivers, o computador encrava e tenho de desligar clicando butão durante alguns segundos.
será que esse comando me bloqueou algumas coisas do proprio jogo?
já tentei instalar os drivers para emulação do Sound Blaster, mas não são instalados correctamente e o Gestor Dispositivos nem os detecta... sim o Windows 98 simula esse audio, mas não tenho os drivers para ele:

Hardware ID PCI\VEN_8086&DEV_266E&SUBSYS_00661025&REV_04
PCI Device Intel 82801FB(M) ICH6(-M) - AC'97 Audio Controller [B2]
não sei, mas até pode ser devido eu instalar o windows 98, num hardware mais recente... mas quero ver se resolvo o problema. muito obrigado
 

Cambalinho

Power Member
desculpa, mas não perguntei nesse sentido. mas perguntei se posso, com linha de comandos, executar esse jogo sem o som.
se é possivel executar só para usar o speaker?
 

DavidJamez

Power Member
já não me recordo bem do jogo mas tenho ideia que sim.
por norma havia um executável à parte para configurar o som, não sei se será o caso desse também
 

Cambalinho

Power Member
nada acontece :(
eu tenho essa versão também, mas nada acontece
tenho de encontrar 1 versão com o ficheiro setup para editar as configurações de som
 

DavidJamez

Power Member
esse portatil não me parece o melhor candidato.
já ponderaste arranjar algum pentium3 ou assim algo mais antigo que suporte placas de som ISA ?
 
Topo