1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.
  2. A secção Microsoft/Windows encontra-se actualmente em processo de reestruturação.
    Remover anúncio

WinXP muito lento no shutdown!

Discussão em 'Windows Desktop e Surface' iniciada por Techdoctor, 28 de Julho de 2006. (Respostas: 71; Visualizações: 10937)

  1. Techdoctor

    Techdoctor Power Member

    Tenho um problema já há algum tempo q me dá a sensação de vir a agravar-se...

    O Windows XP está demasiado lento para encerrar.
    Demora quase 3 min.!!!

    Antes n ligava muito pq o deixava a desligar e ía-me embora, mas já começa a aborrecer-me.

    Tudo o resto funciona bem.

    Está limpo de vírus/spyware/ad-aware/...;
    Está limpo de "temps";
    O Disco está desfragmentado;
    N é muito rápido no arranque mas é aceitável;
    ...

    Aceitam-se ajudas!
     
  2. Sion

    Sion Power Member

    Experimenta fazer uma alteração no registo (mas com cuidado...) como tem na thread dos Tweaks: http://www.techzonept.com/showthread.php?t=36500


    cumps
     
  3. Techdoctor

    Techdoctor Power Member

    Obrigado! [​IMG]

    Vou testar e já digo alguma coisa...
     
  4. Cabalo

    Cabalo Power Member

    faz uma limpeza e desfragmentação do registo.
    Eu costumo usar o Registry Cleaner Expert, e produz resultados palpáveis.
     
  5. Techdoctor

    Techdoctor Power Member

    É pena Sion mas n resultou...
    Está igual.
     
  6. Techdoctor

    Techdoctor Power Member

    Cabalo, eu costumo fazer correções de erros no Registry (uso o Advance Uninstaller Pro 2006),
    embora tenho sp alguns receios em fazer a sua optimização/desfragmentação...

    Mas q n seja por aí. Bora lá testar!
     
  7. Kity

    Kity Power Member

    Boas...olha tenho uma amiga minha que esta exactamente com o mesmo problema que tu e ja formatou pc devido a pensarmos que podia ser sistema e nao resoltou! a ligar por vezes demora 12seg outras ja demora 1min e tal e ate ja xegou perto dos 3min,a desligar aconteçe o mesmo que tu disses-te aconteçer no teu,ja chegou quase aos 3min a desligar! tambem ja desfragmentou o disco e fez as mesmas coisas que tu mas o problema continua.... tambem nao sei nem ela sabe o que fazer para mudar isso! é muito estranho pois tudo o resto aparenta estar bem.
    cump*
     
  8. Techdoctor

    Techdoctor Power Member

    Aceitam-se + sugestões, pois a do Cabalo tb n resultou... Infelizmente! [​IMG]

    Mas melhorou um pouquinho: já encerrou em cerca de 2m30s, mas continua a ser um valor demasiado alto...
     
  9. ec99031

    ec99031 Power Member

    Experimenta o seguinte (atenção isto é só um palpite... Mas pode ser que resulte...):

    Primeiro no windows ctrl+alt+del e vê os processos que estejam a correr. Depois vai desligando os iniciados por ti e vê se algum "custa" mais a desligar. Manda desligar o pc e vê se foi mais rápido...

    Aqui vai a ideia que quero passar: pode haver algum programa (género antivirus) que possa estar a solicitar instruções antes de desligar e por isso enquanto que não "receber" resposta do windows não o deixará desligar... Se formos desligando os processos 1 a 1 (e caso seja este o "mal") acabamos por descobrir qual o prog que está a colocar o pc lento...

    Isto é tipo experimenta e vê se dá... Mas... Tb n tenho nenhuma ideia melhor...

    PS: no arranque pode ser o mesmo, um programa ou serviço que executa instruções antes de iniciar. Normalmente os programas mais "suspeitos" serão anti-virus e processos de rede...
     
  10. Techdoctor

    Techdoctor Power Member

    Como as dicas anteriores (Sion e Cabalo) n resultaram, andei a investigar mais um pouco na net e descobri este link:
    http://www.windowskb.com/Uwe/Forum.aspx/windowsxp/106630/XP-takes-too-long-to-shutdown

    Aí as 3 ideias propostas eram, resumidamente e pela ordem inversa:
    - Executar o já sugerido pelo Sion
    (Como já tinha dito, n resultou)
    - Verificar se n seria o Anti-Virus a atrasar o processo
    (Desliguei-o antes de desligar o PC e o encerramento demorou o mesmo tempo)
    - Verificar se n seria 1 ZIP USB
    (N tenho ZIP mas isso deu-me a ideia de testar com todos os dispositivos USB... Na mesma!)
     
  11. Techdoctor

    Techdoctor Power Member

    Com essa história das portas USB comecei a pensar q o problema realmente tb poderia ser de
    hardware pelo q peguei noutro Disco, formatei-o, instalei o XP (= ao do outro Disco) e mais
    alguns programas comuns q tb tenho no outro, bem como todos os periféricos.
    Ou seja, em termos de hardware ficou =.

    Resultado: Encerramento em 27s !!!

    Por isso, n é hardware!

    Mas no caso da tua amiga, Kity, já me parece q poderá ser algum hardware, pois já experimentaram uma instalação nova e continuou =.
    Vê as portas USB...
     
  12. Techdoctor

    Techdoctor Power Member

    Vamos lá testar a tua idéia...
    Tem lógica e realmente parece-me a única forma de descobrir o q se passa.

    Depois digo o resultado
    (espero q o diga com alegria...)
     
  13. Daniel Maia

    Daniel Maia Colaborador
    Staff Member

    Spyware?

    Testa o ad-ware, spybot search and destroy...e o spysweeper..;)
    cumps
     
  14. Techdoctor

    Techdoctor Power Member

    Agradeço a dica, mas foi por aí q comecei qd o problema me chamou a atenção.
    Verifiquei se tinha vírus tanto no próprio PC (tenho o McAfee instalado e sempre actualizado)
    como tirando o Disco e ligando-o como slave no meu outro PC (onde tenho o Avast);

    Seguidamente fui ver os spywares com todos os programas q tenho (os q indicaste e + 3 ou 4)
    e nada foi detectado.
    [​IMG]
     
  15. Kity

    Kity Power Member

    tambem ja corri o ad-ware o spybot por ai a fora e tambem nao acusou nada! quanto a teres o mcaffe isso é um pouco pesado para o pc (nao significa que seja isso a causa) alem de ser no pc da minha amiga tambem ja é o meu! o meu é mais a ligar porque a desligar desliga rapidamente mas a ligar é muito inconstante,umas vezes demora 12seg outras demora 1min e tal outras 2min e tal e ate ja foi 3min!! passei na loja onde comprei o pc e o tenico disse-me que era normal porque eu tinha o norton na altura e que era pesadissimo loool conclusao que eu pensei: -bem nao posso ter programas pesados se nao entao estou lixada que isto numca mais me sai daqui looool tenho eu um dual-core 3.0 e 1gb de memoria,é normal que demore um pouco mais quando se tem mais programas mas dai a ser tao inconstante vai um passo! depois tirei o norton entao para fazer o que ele disse e coloquei o kaspersky que é super leve e ficou tudo na mesma! programas nao tinha nenhuns,pois o pc tinha acabado de sair da loja e ja estava a fazer essas coisas! mas para o tecnico e para a loja é tudo normal... conclusao tenho eu que tentar resolver problema porque sao uma cambada de incompetentes que tentam ver se arranjam qqcoisa para dizer k é normal desde programas instalados a ser normal enfim...
     
  16. [BoB]Marley

    [BoB]Marley To fold or to FOLD?

    experimenta fazer um ghost do disco que tem esse xp "marado", e vê se no disco "novo" faz o mesmo problema, que é para tirar a dúvida de ser o disco com algum tipo de problema.
     
  17. Techdoctor

    Techdoctor Power Member

    PEOPLE! ESTÁ ENCONTRADA A CAUSA! :banana:
    (no sentido lato, falta agora ir mais ao fundo...)

    Obrigado, ec99031!

    Comecei por fechar todas as aplicações q ficam em memória (canto inferior direito, na barra de tarefas)
    para q n interferissem no teste e depois fiz como disseste:
    1) Ctrl+Alt+Del (para abrir o Gestor de Tarefas)
    2) Cliquei em "Processos"
    3) Cliquei em "Nome de utilizador"
    (para separar os "meus" processos dos do sistema, n fosse eu enganar-me e fazer asneira)
    4) Fechei o processo do meu utilizador q estava a ocupar + memória
    5) Mandei desligar o PC
    (*)

    À 3ª tentativa... Bingo!
    Era simplesmente o EXPLORER! (estava a ocupar cerca de 30MB de RAM)
    O XP encerrou em 17s !!!!!

    Agora falta-me saber o porquê, mas já desconfio...
    Tenho uma pasta no Ambiente de Trabalho com coisas q ando a organizar e q ocupa cerca de 850MB!

    Além disso, n sei se tb afectará, mas a pasta dos Meus Documentos tem quase 8GB!
    (como aparece o atalho da pasta Meus Documentos no Amb. Trab., tb poderá afectar)

    Logo que possa vou fazer os testes q faltam (ou seja, remover tudo o q possa do Amb.Trab.)
    e depois dou-vos + pormenores para o caso de mais alguém ter este problema.


    Grande abraço, ec99031! [​IMG][​IMG][​IMG]


    (*) desculpem os mais sábios mas a explicação é um pouco detalhada para o caso de
    alguém menos sábio querer fazer o mesmo e n souber bem como.
     
    Última edição: 28 de Julho de 2006
  18. ec99031

    ec99031 Power Member

    :):):) Ainda bem que descobriste o problema!!!

    Agora quanto a ser por causa dos ficheiros no Desktop e Meus Documentos... Pode ser... Experimenta copiar tudo o que tens aí para uma pasta a ver se baixa o explorer (depois de reiniciar, claro)...
    É que eu tenho perto de 2GB no desktop e outros 2 nos meus documentos e nunca notei isso... (eu tb n ligo muito pq mando desligar o pc e vou-m embora...)
     
  19. Techdoctor

    Techdoctor Power Member


    Uma coisa q sei q afecta bastante o arranq de 1 PC são configurações de rede.
    Se tiveres placa de rede (seja por cabo ou wireless) podes fazer a experiência (só para testar)
    de a desligares no Gestor de Dispositivos.
     
  20. EJAY

    EJAY [email protected] Member

    Uma coisa é certa. Quanto mais ficheiros estiverem no ambiente de trabalho, mais lento ficará o PC. Agora isso dos Meus documentos causar baixa performance, é capaz de ser verdade, já que o Windows está muito ligado a essa pasta.
    Um conselho que dou é não ocuparem o ambiente de trabalho e nem mesmo a partição donde iniciam o windows, pois quanto menos informação melhor. Ponham antes os vossos ficheiros grandes numa partição separada, é o melhor qu têm a fazer, pois o Windows assim nem dá por eles. :)
    No meu caso, não tenho um único ícone no ambiente de trabalho, não só pela performance, mas também pela estética, já que não gosto de ícones no ambiente de trabalho. Já agora, alguém me sabe dizer como ocultar o ícone da reciclagem?
     

Partilhar esta Página