1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

wpa_supplicant

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por Koncaman, 27 de Maio de 2006. (Respostas: 11; Visualizações: 1249)

  1. Koncaman

    Koncaman Utilizador Saloio

    Boas.
    Ora bem, indo direito ao assunto, alguém aqui tem o linux configurado para aceder a redes do e-U?´tenho andado a tentar configurar o portatil para a rede do IST, e não consigo fazer aquilo trabalhar.

    depois de correr o ipwconfig o gajo passa a reconhecer-me o sinal da rede, mas aceder à net, sem o wpa_supplicant, é impossivel.

    o que se passa é que o portatil (é um portege 2000) tem um controlador de rede integrado com chip da Agere. tudo bem, o WPA supplicant suporta o driver hermes que deve suportar este controlador.
    contudo, não é fornecido com este driver.
    o driver esta disponivel no site da Agere, e eu ja o tenho. acontece que não consigo instalar esta gaita (falha logo no make do driver).

    o wpasupplicant instala-se bem com o apt-get, mas quando não posso usar o apt-get acabam-se as facilidades.

    se alguém aqui tiver a rede configurada, e se identificar com algumas das minhas duvidas, diga qualquer coisa, qualquer dica é bem vinda.
     
  2. madskaddie

    madskaddie Power Member

    Em relação ao driver experimenta o ndiswrapper...
    Só precisas de mais uns comandos em relação a compilar o módulo mas o debian "é amigo" e até nisso te ajuda...segue os passos no wiki que está algures num link do http://ndiswrapper.sourceforge.net . Eu tenho uma rede com WPA-PSK a funcionar OK em casa (basta-me fazer $sudo ifup wlan0 ). No IST ainda não consegui mas preciso de tentar outras soluções [já puz a VPN e tenho cá os scripts, se calhar ainda volto para aqui]. Quando tiveres o ndiswrapper ou o módulo da tua placa a funcionar tenta o que está em:

    http://soe.ddi.pt/viewtopic.php?t=1951


    NOTA: se usares o ndiswrapper (>v1.16), o driver a utilizar com o wpa_supplicant é o "wext" e não o "ndiswrapper"
     
  3. Koncaman

    Koncaman Utilizador Saloio

    antes de mais, obrigado pela ajuda.
    eu acho que ja experimentei o ndiswrapper (que vem com o wpa_supplicant) sem sucesso.
    a placa esta devidamente instalada, e em casa, uso-a sem quaisquer problemas numa rede WEP.
     
  4. acrobat

    acrobat Power Member

    na ESTG de Leiria (rede e-U )é assim:
    wpa_supplicant.conf

    comando pra correr :
    wpa_supplicant -D wext -i eth1 -c /etc/wpa_supplicant.conf

    noutra consola:
    dhclient eth1
     
  5. Koncaman

    Koncaman Utilizador Saloio

    e isso funciona com o wext?
    qual é a controladora wireless do teu portatil?

    estive hoje la no Ciist para ver se o prof que la estava me conseguia configurar isto, e, depois de quase 1h30 de volta daquilo, acabou por desistir da ideia.
    o gajo pareceu-me que percebia daquilo. mas nunca consegui fazer o make do wpa_supplicant com o hermes driver.
    no fim ja estavamos perto da solução, mas ele não tinha muito mais tempo para ver aquilo.

    sempre aprendi mais qualquer coisa.

    tenho que testar o ubuntu 6.06, mas com o pincel que é instalar SO's no portatil, sem leitor de cd's... não estou com muita vontade de trocar.
     
    Última edição: 2 de Junho de 2006
  6. madskaddie

    madskaddie Power Member

    [este post foi escrito atraves da e-U]

    Por fim consegui,

    a alteração mágica foi a introdução (ou alteração) da linha no supplicant.conf:

    ap_scan=2


     
  7. APLinhares

    APLinhares OpenSource Moderator
    Staff Member

    qual o erro que te dava no make ja agora ??
     
  8. Koncaman

    Koncaman Utilizador Saloio

    não era um erro, eram uma lista infindavel.
     
  9. APLinhares

    APLinhares OpenSource Moderator
    Staff Member

    muitos? para parar devia ser so 1 erro :P tao era warnings, suponho ?
    a mim a compilação do wpa corre bem, o problema é dps kd tento usar o wpa :(
     
    Última edição: 11 de Junho de 2006
  10. Koncaman

    Koncaman Utilizador Saloio

    mas o WPA_supplicant instala-se bem. o apt-get tratou de instalar convenientemente aquilo (ainda assim, é uma versão um bocado antiga, se souberem de repositorios com versões mais recentes avisem).

    o problema é com a instalação do hermes driver.
    não faço ideia como por o driver hermes a funcionar com o Wpa_supplicant.
    a instalação do hermes driver da uma lista infindável de erros.

    e a instalação do WPA_supplicant sem ser com o apt-get também não é muito diferente.

    se for tirando opções ao WPA_supplicant.conf a coisa vai-se acertando, mas às tantas estou a capar o programa todo, e aquilo ainda não faz o make como deve ser.

    eu ja fui estive no CIIST (andre regateiro) para ver se me resolviam o problema, ele não tinha muito tempo para ver isto, mas ainda andou aqui a tentar safar-me isto e não conseguiu.

    acho que com o fedora é possivel fazer a configuração disto pelo ambiente grafico. no ciist também me disseram para instalar o ubuntu 6.06 para ver se me safava com uma versão mais recente do wpa_supplicant...
    mas é tão chato instalar um SO no portatil que não estou muito entusiasmado com a ideia...

    depois, na internet aparece muita coisa sobre o hermes driver, mas nada ajuda especificamente a resolver o problema. o ideal seria um WAP_supplicant com o hermes driver ja integrado. porque para o integrar... vai la vai.
     
  11. madskaddie

    madskaddie Power Member

    antes de reinstalar SO novo de raiz, experimenta primeiro um live CD... pode ajudar sem teres de comecar tudo do inicio...
     
  12. Koncaman

    Koncaman Utilizador Saloio

    pois, eu ate experimentava, mas eu não tenho leitor de cd's no portatil :P
     

Partilhar esta Página