1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

xampp localhost

Discussão em 'Web Development' iniciada por DaNi_Surfer, 10 de Março de 2009. (Respostas: 16; Visualizações: 7086)

  1. Digito "localhost" ou "localhost/site/index.php" no meu browser mas ele n reconhece e redireciona para o google.

    Antes não tinha este problema, começou assim do nada.

    Alguém aqui sabe como resolver isto? obrigado.
     
  2. vai ao xampp e liga o Apache ( é o primeiro a selecionar ) ja o tens ligado?
     
  3. geoblast

    geoblast Power Member

    o host do windows aponta o 127.0.0.1 para o localhost?
     
  4. Sim, já o tenho ligado.
    Eu tenho os serviços apache, mysql e Filezilla instalados, mas o unico que ta ligado é o Apache.
    Se eu tento desligar o Apache ele diz "Busy Error: -1"
    Se tento ligar o mysql ou filezilla ele diz "Busy Error: Mysql service not started [-1]"


    Desculpa a ignorancia mas como vejo isso?
     
  5. geoblast

    geoblast Power Member

    Na pasta windows\system32\drivers\etc, se não estou em erro
     

  6. Ja fui ai, o endereço que tem la para o localhost é 1 e não 127.0.0.1 :S, ja tentei mudar mas o acesso é negado.

    Ja consegui aceder ao localhost atraves do endereço 127.0.0.1 e consigo mecher na base de dados mas não consigo ver o meu site no endereço 127.0.0.1/site/index.php , aparece
    "NÃo é possível selecionar a Base de Dados"
     
  7. geoblast

    geoblast Power Member

    Não podes editar o ficheiro aí. Copias o ficheiro para um sítio que possas editar, tipo desktop, e substituis esse tal 1 por 127.0.0.1 localhost, gravas e copias o ficheiro alterado para a pasta etc.
     
  8. ok ja mudei o ip mas continua a não dar, o ficheiro esta assim:

    # Copyright (c) 1993-2006 Microsoft Corp.
    #
    # This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
    #
    # This file contains the mappings of IP addresses to host names. Each
    # entry should be kept on an individual line. The IP address should
    # be placed in the first column followed by the corresponding host name.
    # The IP address and the host name should be separated by at least one
    # space.
    #
    # Additionally, comments (such as these) may be inserted on individual
    # lines or following the machine name denoted by a '#' symbol.
    #
    # For example:
    #
    # 102.54.94.97 rhino.acme.com # source server
    # 38.25.63.10 x.acme.com # x client host
    # 127.0.0.1 localhost


    Algo errado?
     
  9. rdgomes

    rdgomes Power Member

    Se tens 1, acede pelo: 1/site/index.php


    Edit: Tens de retirar o '#' na última linha: 127.0.0.1 localhost
     
    Última edição: 11 de Março de 2009

  10. Ja retirei o #, mas continuo a não conseguir aceder digitando localhost, e não consigo entrar no meu site no endereço 127.0.0.1/site/index.php :005:
     
  11. rdgomes

    rdgomes Power Member

    Pode ser das configurações do xamp. Vai á pasta onde ele está instalado e /apache/conf/httpd.conf
    Diz-me o que aparece no ServerName.
     
  12. O problema já fo resolvido, esta a funcionar perfeitamente.

    Muito obrigado pela ajuda a tds os que me responderam ;).
     
  13. geoblast

    geoblast Power Member

    Já agora, como resolveste?? É importante saber, para quem tiver o mesmo problema.
     
  14. Apenas fiz o que vcs me disseram, só que por alguma razão ele não reconheceu de imediato a modificação que fiz, já não é a primeira vez que isto me acontece, modifico algo, não altera nd e dps de algum tempo sem mais modificações fica bom.

    Foi como vcs disseram, ir até ao host por o nome localhost a redirecionar para o 127.0.0.1 e tá la.Obrigado.
     
  15. naoliveira

    naoliveira Power Member

    sempre que fazes alguma alteração a nivel de servidor web comvém a seguir fazeres o restart ao Apache.
     
  16. OldMan

    OldMan Power Member

    Eu não uso o xampp nem windows, uso mamp em mac MAS:

    Não é suposto acederes por uma porta específica? Nas preferences do mamp tenho lá "apache port: 8888" e depois no browser tenho que aceder por http://localhost:8888/ se tentar sem a port também não dá nada.
     
  17. Hugo_Carvalho

    Hugo_Carvalho Power Member

    Isso depende do que defines no httpd.conf em Listen e em ServerName
    Para o XAMPP para windows, penso que vem com a 80 por default.
     

Partilhar esta Página