1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

XMB Forum - email

Discussão em 'Web Development' iniciada por ugo_asus, 29 de Janeiro de 2008. (Respostas: 8; Visualizações: 813)

  1. ugo_asus

    ugo_asus Power Member

    Olá...eu instalei um forum XMB...mas o email nao funciona...tipo os utilizadores nao recebem o email com a password....

    Alguem me pode ajudar?
     
  2. spastikman

    spastikman Banido

    ou vai para o spam, ou então tens de configurar o serviço de mail. Imforma-te no painel de controlo e junto da tua empresa de alojamento.
     
  3. ugo_asus

    ugo_asus Power Member

    Não vai para spam...eu já configurei...mas continua a não dar...
     
  4. Santo38

    Santo38 Power Member

    Se continua a não dar é porque algo está errado. Ou colocas aqui mais dados de erro ou a configuração que efectuas-te ou só por dizer "não dá", vai ser muito complicado ajudar-te.

    Saudações
     
  5. ugo_asus

    ugo_asus Power Member


    ok....

    aqui está a parte do config.php

    $mailer['type'] = 'socket_SMTP';

    // mailer-options (for socket_SMTP only, currently)
    $mailer['username'] = '*****';
    $mailer['password'] = '****';
    $mailer['host'] = 'smtp.***.pt';
    $mailer['port'] = '25';

    o smtp está afuncionar porque já testei num programa que fiz....

    .....

    Agora quando chega a parte do registo...onde aparece a mensagem "A password foi enviada para o seu email."....aparecem estes erros:

    Warning: fsockopen(): unable to connect to smtp.****.***:25 in /home/www/****.*****.com/forum/include/smtp.inc.php on line 53

    Warning: fwrite(): supplied argument is not a valid stream resource in home/www/****.*****.com/forum/include/smtp.inc.php on line 99

    Warning: fgets(): supplied argument is not a valid stream resource in home/www/****.*****.com/forum/include/smtp.inc.php on line 103

    Warning: fwrite(): supplied argument is not a valid stream resource in home/www/****.*****.com/forum/include/smtp.inc.php on line 99

    Warning: fwrite(): supplied argument is not a valid stream resource in home/www/****.*****.com/forum/include/smtp.inc.php on line 99

    Warning: fgets(): supplied argument is not a valid stream resource in home/www/****.*****.com/forum/include/smtp.inc.php on line 103

    Warning: fwrite(): supplied argument is not a valid stream resource in home/www/****.*****.com/forum/include/smtp.inc.php on line 99



    Se precisarem de mais info digam-me que eu disponibilizo....

    Cumps,
     
  6. Santo38

    Santo38 Power Member

    Em vez de SMTP o software não tem opção para usar a função mail() do php? Se tiver habilita-a que provavelmente resolve o problema.

    Saudações
     
  7. ugo_asus

    ugo_asus Power Member


    Tipo eu não percebo muito disto...no inicio estava como default....usava a funcao mail()...mas não enviava mails...o que é que é preciso configurar?
     
  8. Santo38

    Santo38 Power Member

    Com a função mail() do php não necessitas de configurar nada.. Em teoria ele usa directamente o "sendmail" do linux para enviar o correio. Presumo que o teu alojamento é Linux.. (cPanel?)

    Saudaçoes
     
  9. ugo_asus

    ugo_asus Power Member

    Problema resolvido....não tinha a opcao email ligada no alojamento.....:zzz:

    Obrigado
     

Partilhar esta Página