1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

ZAPP e Feisty

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por Taj, 4 de Abril de 2007. (Respostas: 8; Visualizações: 994)

  1. Taj

    Taj

    Olá malta,

    estou a tentar instalar ZAPP no feisty e consigo instalar o script corre tudo bem, mas quando faço o comando z020-connect aparece-me este erro:

    Código:
    /usr/sbin/pppd: By default the remote system is required to authenticate itself
    /usr/sbin/pppd: (because this system has a default route to the internet)
    /usr/sbin/pppd: but I couldn't find any suitable secret (password) for it to use to do so.
    /usr/sbin/pppd: (None of the available passwords would let it use an IP address.)
    
    
    Alguém tem alguma sugestão? Estou mesmo À nora e já me custa um bocado usar windows... :)
     
  2. Boas.

    Já colocas-te o username e pass de acesso??
     
  3. Taj

    Taj

    Sim, :)

    Eu já tive isto a funcionar no edgy e desta vez fiz tudo como antes. :)
     
  4. Prodigy

    Prodigy Suspenso

    Nunca exprimentei colocar o Zapp em linux, mas a questão de usar um default gateway, vê primeiro como "su"

    Código:
    route -n
    e faz delete ao gateway predefenido que deve ser o 0.0.0.0

    Código:
    route -vF del default gateway
     
  5. mundano

    mundano Power Member

    Porque é que em vez do Script não usas apenas o Gnome PPP? Penso que torna as coisas mais simples....
     
  6. Taj

    Taj

    @Prodigy
    Código:
    Destino         Roteador        MáscaraGen.    Opções Métrica Ref   Uso Iface
    192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1
    169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth1
    0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 eth1
    
    No meu caso, qual será o default gateway?

    @Mundano, sim já pensei nisso mas no número de telefone meto o quê? Sei que no modem z010 o número era #777, mas com o z020 esse número não funciona.
     
  7. mundano

    mundano Power Member


    Configuração da Ligação (Z020)
    Seguem-se os dados necessários à configuração da ligação:
    1. Dispositivo: /dev/ttyUSB0
    2. No a marcar: #777
    3. Nome de Utilizador: 949xxxxxx
    4. Palavra-Passe: Código de Acesso

    E tens que ter um kernel igual ou superior ao 2.6.18..
     
  8. Taj

    Taj

    Funciona. :D
    Eu estava a fazer tudo como tens aí, mas não funcionava. Estranhamente activei a opção de "voltar a ligar ao desconectar" e passou a funcionar. :)
    Thanks :)
     
  9. Wickwire

    Wickwire Power Member

    Uma das causas para esse erro do pppd (não sei se outras existirão) está relacionada com o facto de estarem activos outros interfaces de rede, mesmo que não tenham ligação estabelecida - ex. placas de rede sem fios ou de cabo de rede.

    Aconteceu-me anteriormente com o Edgy, pode ter estado na origem do teu erro inicial, de qualquer forma sendo que é Ubuntu, é de facto mais simples configurar as ligações PPP pelo Network Settings que já vem com Gnome.
     

Partilhar esta Página