1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Ajuda imagens no Access!!!

Discussão em 'Programação' iniciada por ivo_sagres, 16 de Março de 2008. (Respostas: 2; Visualizações: 1765)

  1. ivo_sagres

    ivo_sagres Power Member

    Boas pessoal, estou aqui a fazer uma miniBD e preciso da vossa ajuda.
    Numa tabela, tenho um campo que é objecto OLE. Fiz um formulário para inserir dados e no campo das imagens só aparece imagem se for BMP se puser por exemplo um JPG já só aparece o nome...
    E mais fiz um relatório, mas no campo da imagem não aparece nada, seja JPG ou BMP...
    Alguém tem uma dica(não precisa ser a da semana lol)
    Agradeço desde já a vossa ajuda...
     
  2. ivo_sagres

    ivo_sagres Power Member

    Pessoal, uma ajudinha plz
     
  3. kzip

    kzip Power Member

    O Access não tem suporte nativo para outros formatos de imagem além do BMP. Julgo que usa o "engine" do Paint para visualizar as imagens.
    Acho que há formas de contornar a questão, mas não é muito aconselhável, pois não são propriamente soluções "universais". O melhor é mesmo usares imagens em formato BMP. E o que perdes na dimensão da imagem ganhas no "overhead" que o OLE gera (o overhead do Paint é muito menor que o de outro programa de tratamento de imagem qualquer).

    Não vejo nenhuma razão para o BMP não aparecer no relatório. teve ter falhado aí alguma coisa. Tenta fazer um novo relatório através do "assistente", para ver se assim aparece.
     

Partilhar esta Página