1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

AJUDA OsCommerce

Discussão em 'Web Development' iniciada por paulo_tec, 22 de Setembro de 2008. (Respostas: 11; Visualizações: 976)

  1. paulo_tec

    paulo_tec Power Member

    Estou a tentar instalar um template de oscommerce que arranjei na net, só que quando o vou a instalar dá-me um erro "Access denied for user 'admin'@'localhost' (using password: YES)"
     
  2. Santo38

    Santo38 Power Member

    Esse erro não tem nada a ver com o template, mas sim com a base de dados. Quere-me parecer que o ficheiro de configuração não tem os dados corectos.

    Saudações
     
  3. paulo_tec

    paulo_tec Power Member

    O erro que me está a dar é este

    [​IMG]
     
  4. Santo38

    Santo38 Power Member

    Repito o que disse anteriormente. A configuração dos dados da base de dados e respectivo acesso estão errados e por isso aparece esse erro.

    Saudações
     
  5. Pedrovsky

    Pedrovsky [email protected] Member

    se tas a instalar isso em wamp a base de dados deverá ser root(supondo que não alteraste) ou não sei,isso também não deverá ter nada a ver com a template mas sim com a base de dados como já aqui disseram.
    Vê lá da base de dados e depois diz aqui alguma coisa :002:
     
  6. paulo_tec

    paulo_tec Power Member

    eu criei a base de dados e o utilizador com acesso a todas as opções da base de dados, estou a utilizar a base de dados e esse utilizador e dá-me esse erro

    poderei colocar aqui pics a demonstrar essa configuração para ver se me podem ajudar pf ?
     
  7. Pedrovsky

    Pedrovsky [email protected] Member

    se tens a certeza que o user na base de dados é o admin e a base de dados é em localhost e se criaste a base que queres e meteste para lá devia de dar.
    senão tenta dar mais permissões na pasta do servidor onde tens o oscommerce.
    Se não conseguires posta ai para podermos ver como fizeste :P
     
  8. paulo_tec

    paulo_tec Power Member

    estive a ver as permissoes da pasta (onde esta colocado o template "...\loja\install) no servidor e está 755

    [​IMG]

    [​IMG]

    penso que esta tudo correcto ???
     
  9. Pedrovsky

    Pedrovsky [email protected] Member

    tens uma base de dados criada por exemplo no phpmyadmin chamada root?no admin e nessa pass?
    dá privilégios 777 a ver
     
  10. paulo_tec

    paulo_tec Power Member

    quando abro o phpmyadmin tenho uma mensagem que diz que não tenho previlégios para criar nova base de dados, tenho por isso de a criar pelo cpanel
    como posso ver no phpmyadmin o utilizador que esta agregado a uma determinada base de dados e quais as suas permissoes

    [​IMG]
     
  11. Santo38

    Santo38 Power Member

    Só uma dica: nunca vais poder usar root para a base de dados se tens uma conta cPanel. O nome da tua base de dados é comptok_root e não root. O user é comptok_admin e não admin.

    Saudações
     
  12. paulo_tec

    paulo_tec Power Member

    já está resolvido

    obrigado a todos
     

Partilhar esta Página