1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.
  2. A secção Microsoft/Windows encontra-se actualmente em processo de reestruturação.
    Remover anúncio

Formulas no exel preciso de ajuda

Discussão em 'Windows 7 e anteriores' iniciada por fabio-8800gts, 22 de Outubro de 2008. (Respostas: 3; Visualizações: 621)

  1. fabio-8800gts

    fabio-8800gts Power Member

    Olá boa noite.
    Estou a fazer um trabalho no exel para o meu curso de informática e uma das formulas não me da bem....


    Se a nota for inferior a 5 a, classificação é "muito fraco"
    Se a nota estiver entre 5 e 10, a classificação é "Fraco"
    Se a nota estiver entre 10 e 13, a classificação é "suficiente"
    Se a nota estiver entre 13 e 17, a classificação é "bom"
    Se a nota for superior a 17, a classificação é "Muito bom"

    =SE(E2<5;"muito fraco";se(E2>5<10;"fraco";se(E2>10<13"suficiente";se(E2>13<17"bom";se(E2>17"muito bom")))))


    O erro da onde está a vermelho. A coluna do E e onde está a media de notas de 2 testes e um trabalho.

    Se puderem ajudar....
    Abraço
     
  2. olly

    olly Power Member

    Não precisas de complicar tanto:
    =SE(A1<5;"Muito Fraco";SE(A1<10;"Fraco";SE(A1<13;"Suficiente";SE(A1<17;"Bom";"Muito Bom"))))

    O teu erro foi isto "E2>5<10" este tipo de condição não funciona.
    E tem atenção para não te esqueceres dos ";" a separar as condições:

    se(E2>13<17"bom";se(E2>17"muito bom")
     
  3. Zylmhuin VII

    Zylmhuin VII Power Member

    Testa assim:

    =SE(E2<0;"ERRO";SE(E2<5;"muito fraco";se(E2<10;"fraco";se(E2<13;"suficiente";se(E2<17;"bom";se(E2<=20;"muito bom";se(E2>20;"ERRO")))))))

    As condições a sublinhado são uma segurança, para se por alguma razão a nota der inferior a 0 ou superior a 20. Se quiseres, podes tirar.

    EDIT: Não precisas de coisas do tipo E2>5<10, porque só entra nessa condição se E2>=5.
    Além disso, na tua fórmula, estavas a excluir os 5, 10, 13 e 17...
     
  4. fabio-8800gts

    fabio-8800gts Power Member

    Já consegui.... Muito obrigado ... estes erros são terriveis
    Cumpz
     

Partilhar esta Página