1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Freemind - problemas com o Java

Discussão em 'Dúvidas e Suporte Técnico - GNU/Linux & *nix' iniciada por (in)dependente, 12 de Fevereiro de 2008. (Respostas: 0; Visualizações: 1291)

  1. (in)dependente

    (in)dependente Power Member

    Muito boa noite.

    Instalei o Freemind no meu Ubuntu 7.10 com o intuito de lhe dar uso. No entanto, apesar de ter sido avisado para instalar a versao 5 do java (problemas com a versão 6), não consigo fazer correr o programa

    Código:
    ERROR:   Your Java is not a derivative from Sun's code,
             =======================================
             FREEMIND WILL MOST PROBABLY *NOT* WORK,
             =======================================
             define JAVACMD, JAVA_BINDIR, JAVA_HOME or PATH in order
             to point to such a VM. See the manpage of freemind(1) for details.
    Exception in thread "main" java.awt.AWTError: Cannot load AWT toolkit: gnu.java.awt.peer.gtk.GtkToolkit
       at java.awt.Toolkit.getDefaultToolkit(libgcj.so.81)
       at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(libgcj.so.81)
       at java.awt.Window.<init>(libgcj.so.81)
       at java.awt.Frame.<init>(libgcj.so.81)
       at javax.swing.JFrame.<init>(libgcj.so.81)
       at freemind.main.FreeMind.<init>(FreeMind.java:107)
       at freemind.main.FreeMind.main(FreeMind.java:647)
    Caused by: java.lang.UnsatisfiedLinkError: libgtkpeer: libgtkpeer.so: não é possÃ*vel abrir objecto partilhado: Ficheiro ou directoria inexistente
       at java.lang.Runtime._load(libgcj.so.81)
       at java.lang.Runtime.loadLibrary(libgcj.so.81)
       at java.lang.System.loadLibrary(libgcj.so.81)
       at gnu.java.awt.peer.gtk.GtkToolkit.<clinit>(libgcj.so.81)
       at java.lang.Class.initializeClass(libgcj.so.81)
       at java.lang.Class.forName(libgcj.so.81)
       at java.awt.Toolkit.getDefaultToolkit(libgcj.so.81)
       ...6 more
    Já vi no Gestor de Pacotes Synaptic e tenho o sun-java5-jre instalado, assim como, a versão 6!

    Estará a usar na mesma a versão 6 do java? Terei que remover a versão mais actualizada para que o programa funcione? E, com isso, não irá afectar outros programas que utilizam plataforma java?!

    Dicas...? Sugestões...?
     

Partilhar esta Página