1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Install Deluge

Discussão em 'Dúvidas e Suporte Técnico - Apple' iniciada por eLias, 9 de Abril de 2008. (Respostas: 21; Visualizações: 3225)

  1. eLias

    eLias Power Member

    Boa tarde pessoal.
    Sempre usei o deluge e acho que é o melhor cliente para torrents no windows para quem sofre do TS da netcabo.
    Recentemente migrei para Mac OSX e pelo que tenho visto não é anda fácil instalar o deluge.
    Na página do programa, diz para correr dois comandos após instalar o Mac Ports :
    sudo port selfupdate
    sudo port install deluge

    Código:
    MacPorts base version 1.600 installed
    
    Downloaded MacPorts base version 1.600
    
    The MacPorts installation is not outdated and so was not updated
    selfupdate done!
    31:~ paulolima$ sudo port install deluge
    --->  Building boost with target all
    Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_boost/work/boost_1_34_1" && gmake all " returned error 2
    Command output: Makefile:2: *** missing separator.  Stop.
    
    Error: The following dependencies failed to build: boost librsvg libart_lgpl libcroco libgsf gnome-vfs desktop-file-utils popt gconf gtk2 atk cairo fontconfig freetype libpng render xrender gtk-doc gnome-doc-utils docbook-xml docbook-xml-4.3 docbook-xml-4.4 docbook-xml-4.5 iso-codes py25-hashlib openssl p5-xml-parser perl5.8 py25-libxml2 rarian intltool gnome-common jpeg pango Xft2 xorg-xproto xorg-util-macros shared-mime-info tiff orbit2 libidl gnome-mime-data libbonobo py25-gtk libglade2 py25-cairo py25-numpy fftw-3 g95 py25-xdg py25-zlib
    Error: Status 1 encountered during processing.
    
    Obtenho esse erro depois de escrever no terminal sudo port install deluge
    Tenho o Xcode tools instalado, que vinha no 2º Dvd do Leopard, tenho o X11 também instalado e o python, alguém já o conseguiu instalar? Alguém sabe a que se pode dever o erro acima?
    Cumprimentos
     
    Última edição: 9 de Abril de 2008
  2. eLias

    eLias Power Member

    Parece que ninguém instalou o deluge :)
    Já agora, alguém sabe como fechar a tampa do mac com o leopard e o sistema não entrar em standby? Sei la, por vezes estamos apenas com a bateria e queremos deixar o portátil a fazer downloads. Fechar o ecrã, o ecrã entrar em sleep mas o portatil continuar a operar?
    É uma operação bastante fácil e pratica no windows. Sei que com o exposé já é possivel por o ecrã em sleep mas não existe forma de o fechar sem o computador ir para standby ? Penso que com um programa chamado insomniax, ele evita que o pc vá para standby mas não sei se desligar o monitor...
    Cumps
     
  3. rui_m7

    rui_m7 Power Member

    Já foi discutido.
    O InsomniaX não faz nada ao monitor. O que pode fazer é desligar o monitor, ligar o InsomniaX e ai sim fechar a tampa.

    Cumps
     
  4. s e 7 e n

    s e 7 e n Power Member

  5. eLias

    eLias Power Member

    Foi uma boa dica Seven, de facto resolvi os primeiros erros mas depois acabaram por aparecer outros. Pensava que estava tudo resolvido quando ao fim de quase uma hora a instalar o deluge, acabou por gerar um outro erro que não estava lá listado :(
    Obrigado,
    Cumps
     
  6. s e 7 e n

    s e 7 e n Power Member

    os outros erros que aprecem resolves da mesma maneira....
    aquilo anda sempre pelo...
    sudo port clean pkg
    sudo port install pkg
    sudo port install deluge

    Eu ja o tive a trabalhar, depois meti uns plugins que o mataram...
    Agora ando praqui a apagar ficheiros mão conforme da os erros de compilação.

    Mas em termos de velocidade quando tens TS é muito melhor que Transmission e Azureus com as definições para controlar o TS.
     
  7. eLias

    eLias Power Member

    Exactamente, por isso é que queria muito ter o deluge aqui no mac, estava habituado em windows e era sem dúvida o melhor principalmente no que toca a TS. Sinceramente já tinha percebido isso no thread que me tinhas dado mas ainda não consegui. Vou agora tentar novamente. Já agora quando conseguiste instalar quanto tempo demorou no total?
    Já agora, tinha andado a ler umas coisas também por causa do deluge em que se alterava o .profile.
    Agora obtenho este erro:
    Last login: Fri Apr 11 12:30:38 on console
    -bash: i: command not found
    -bash: export: `PATH#': not a valid identifier
    macbook-air-de-paulo-lima:~ paulolima$

    Como removo o profile ou as alterações?
    Cumps e obrigado.
     
  8. eLias

    eLias Power Member

    BTW, agora estou neste erro que me deixa com poucas esperanças :S

    Código:
    macbook-air-de-paulo-lima:~ paulolima$ sudo port install deluge
    --->  Building deluge with target build
    Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_deluge/work/deluge-torrent-0.5.8.7" && /opt/local/bin/python2.5 setup.py build " returned error 1
    Command output: libtorrent/src/alert.cpp:83: error: expected `;' before 'lock'
    libtorrent/src/alert.cpp:89: error: 'boost' has not been declared
    libtorrent/src/alert.cpp:89: error: 'xtime' was not declared in this scope
    libtorrent/src/alert.cpp:89: error: expected `;' before 'xt'
    libtorrent/src/alert.cpp:90: error: 'boost' has not been declared
    libtorrent/src/alert.cpp:90: error: 'xt' was not declared in this scope
    libtorrent/src/alert.cpp:90: error: 'boost' has not been declared
    libtorrent/src/alert.cpp:90: error: 'TIME_UTC' was not declared in this scope
    libtorrent/src/alert.cpp:90: error: 'xtime_get' was not declared in this scope
    libtorrent/src/alert.cpp:92: error: 'boost' has not been declared
    libtorrent/src/alert.cpp:99: error: 'm_condition' was not declared in this scope
    libtorrent/src/alert.cpp:99: error: 'lock' was not declared in this scope
    libtorrent/src/alert.cpp: In member function 'void libtorrent::alert_manager::post_alert(const libtorrent::alert&)':
    libtorrent/src/alert.cpp:107: error: 'boost' has not been declared
    libtorrent/src/alert.cpp:107: error: 'scoped_lock' was not declared in this scope
    libtorrent/src/alert.cpp:107: error: expected `;' before 'lock'
    libtorrent/src/alert.cpp:118: error: 'm_condition' was not declared in this scope
    libtorrent/src/alert.cpp: In member function 'std::auto_ptr<libtorrent::alert> libtorrent::alert_manager::get()':
    libtorrent/src/alert.cpp:123: error: 'boost' has not been declared
    libtorrent/src/alert.cpp:123: error: 'scoped_lock' was not declared in this scope
    libtorrent/src/alert.cpp:123: error: expected `;' before 'lock'
    libtorrent/src/alert.cpp: In member function 'bool libtorrent::alert_manager::pending() const':
    libtorrent/src/alert.cpp:134: error: 'boost' has not been declared
    libtorrent/src/alert.cpp:134: error: 'scoped_lock' was not declared in this scope
    libtorrent/src/alert.cpp:134: error: expected `;' before 'lock'
    libtorrent/src/alert.cpp: In member function 'void libtorrent::alert_manager::set_severity(libtorrent::alert::severity_t)':
    libtorrent/src/alert.cpp:141: error: 'boost' has not been declared
    libtorrent/src/alert.cpp:141: error: 'scoped_lock' was not declared in this scope
    libtorrent/src/alert.cpp:141: error: expected `;' before 'lock'
    error: command '/usr/bin/gcc-4.0' failed with exit status 1
    
    Error: Status 1 encountered during processing.
    macbook-air-de-paulo-lima:~ paulolima$ 
    
     
  9. s e 7 e n

    s e 7 e n Power Member

    Esse agora é mais dificil...
    Tas como eu, tenho um erro tipo esse de cenas que n foram declaradas... mas em vez de ser do python2.5 é do py2.5-gtk.
    Mas tambem tive um erro qualquer do python25 com o setup.py.

    Epah, a 1º vez a fazer o compile e o install do deluge todo demora bastante tempo.
    La no forum deles estava la gente a demorar 4horas, eu deixei o meu a fazer isso e sai de casa.

    Eu depois quando o tinha a trabalhar, fui-lhe instalar uns plugins... matei aquilo tudo.
    Tive que estar a apagar pacote a pacote e depois instalar pacote a pacote a mão e a remover os ficheiros já existentes do finder... no fim tinha cerca de 1500 ficheiros na Reciclagem.
    Agora da-me um erro desse genero mas no py25-gtk...
    Mas eu vou ver se descobro alguma coisa.

    Mas tenha o:
    sudo port clean python2.5
    sudo port install python2.5
     
  10. luis carradinha

    luis carradinha Power Member


    Boas eu tenho instalado no meu MAC o VMwere fusion e nao tive problema nenhuma em instalar o deluge na partiçao windows.Fui ao sait deles sakein o ficheiro de instalaçao,e foi dois minutos ,instalei o deluge, e tá a bombar a 1.9 megas ....Só tem um problemaao fim de algum tempo o deluge perde as veloçidades e fika a sacar a 10 kbs .....pra resolver o problema desenstalo o deluge e volto a instala-lo , e fika de novo *****.


    comps
     
  11. eLias

    eLias Power Member

    Por acaso já me aconteceu isso mas é quando estou no CC Parque Nascente, tem muitas quebras mas penso que seja da ligação lá :) . Também já instalei através do VMWare mas se estás apenas a usar a bateria, ela consome-se mais depressa se estás a usar uma aplicação pesada como o VMWare a correr um SO . Por isso pretendia instalar no MAC OSX também mas por uns tempos desisti :( .
    Cumps
     
  12. deicide1976

    deicide1976 Power Member

    oi pessoal...confesso q passei toda a tarde a ver se o conseguia instalar mas ta visto q tenho mesmo q desistir,nao consigo...abraco
     
  13. rjrp

    rjrp Power Member

    Eu já tentei, mas não consegui instalar o deluge, eu instalei o macports, depois abro o terminal e meto:
    Sudo port selfupdate
    e diz logo: "sudo: port: command not found|"

    Alguém pode dar uma ajudinha?! É que não percebo nada do macports...
     
  14. tourist

    tourist Power Member


    o mesmo comigo.
    tentei instalar o porticus para ajudar a instalar o delegue mas nem assim, dá um erro qq...
    lg posto qual
     
  15. rjrp

    rjrp Power Member

    O problema será eu utilizar o Leopard?

    Já agora, o que é o Porticus?

    Eu estava a tentar instalar através do terminal... Primeiro dava-me port: command not found, essa questão já resolvi.
    Agora quando faço sudo port install deluge por vezes aparece qualquer coisa escrita em baixo, corre um bocadito mas depois parece que bloqueia... já deixei cerca de 15 minutos e nada...

    Enquanto não tiver o Deluge vou usando o Vuze com o qual consegui melhorar um bocado a velocidade dos torrents
     
  16. tourist

    tourist Power Member

    Porticus is a Cocoa GUI for the MacPorts package manager
    podes ver melhor aqui: http://porticus.alittledrop.com/

    já agora como é que ultrapassas te o command not found?

    Com o Vuze consegues velocidades decentes?
     
  17. rjrp

    rjrp Power Member

    Com o vuze consigo 180 a 200 kbps no maximo durante a noite
    Nao estou no meu mac mas mais lg ja te posso dizer como fiz, vi no google, tens que adicionar a path ao .bash
     
  18. s e 7 e n

    s e 7 e n Power Member

    Diz qual foi o ficheiro que te deu erro a instalar que isso resolve-se...

    Como disse la em cima, anda sempre por usar estes comandos:
    sudo port clean 'pkg'
    sudo port install 'pkg'
    sudo port install deluge

    em que o 'pkg' é o package que da erro a instalar...
     
  19. tourist

    tourist Power Member

    sudo: port: command not found
    nmartins:~ martinsnunomiguel$ sudo port clean 'pkg'
    sudo: port: command not found
    nmartins:~ martinsnunomiguel$
     
  20. s e 7 e n

    s e 7 e n Power Member

    A solução do do erro que não encontra o port podes resolver por aqui...

    Se não me engano aquele ficheiro esta na dir do teu user, em oculto.


    Os outros codigos que disse é para quando já se esta a instalar o deluge e da erros em certos packages.
     

Partilhar esta Página