1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

O gravador de DVD está sempre em modo PIO

Discussão em 'Dúvidas e Suporte Técnico PC' iniciada por nfh, 19 de Fevereiro de 2008. (Respostas: 4; Visualizações: 1445)

  1. nfh

    nfh Power Member

    Comprei um NEC Optiarc AD-7191A e aparece sempre em modo PIO no windows XP.
    Ainda que tenha "DMA if available", o Current Transfer Mode está sempre em PIO Mode.

    No entanto já verifiquei que o gravador aparece em modo PIO 4 Ultra 4 no ecrã de boot (aquele ecrã inicial em modo de texto), pelo que tudo indica que é o XP que está a armar-se em esquisito com o gravador.

    Alguma dica para resolver este problema?

    Cumps.
     
  2. balute

    balute Power Member

    Tenta estas possíveis soluções:
    - Muda o modo para PIO, clica OK, vai lá outra vez e muda para DMA, clica OK e reinicia o PC.
    - Nas chaves de registo HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\000X (onde X é um número), apaga os valores MasterIdDataCheckSum e SlaveIdDataCheckSum, e reinicia o PC.
    - Se tiveres o Intel Application Accelerator instalado, desinstala-o, e reinicia o PC.
     
  3. nfh

    nfh Power Member

    Agora estou no trabalho, mas quando chegar a casa vou testar isso.

    Se não me engano essa é uma das "técnicas" para reiniciar o canal IDE. É que o novo gravador de DVD veio substituir um que pifou. O mais certo é a unidade defeituosa ter gerado os CRC errors suficientes para o XP fazer regredir a velocidade do canal IDE.

    Há outra hipótese que se calhar até vou tentar em primeiro lugar: desinstalar o controlador IDE secundário (ao qual está ligado o DVD) e ver se ao reinstalá-lo já fica em modo UDMA66.
     
  4. balute

    balute Power Member

    Nem me lembrei disso. Em princípio, basta desinstalar o controlador e fica logo resolvido. ;)
     
  5. nfh

    nfh Power Member

    Bem, o truque de desinstalar o controlador IDE e voltar a instalá-lo resultou.
    No entanto tenho agora outro problema: no mesmo cabo IDE tenho o gravador de DVD (master) e um gravador de CD's TEAC (slave). O gravador de CD's já tem uns anitos e funciona em modo UDMA33 (salvo erro PIO 4 UDMA 2). Ora o gravador de DVD's aparece em modo UDMA66 (PIO 4 UDMA 4).
    Tenho, portanto, 2 dispositivos no mesmo cabo com modos DMA diferentes. Isto pode ser problemático? É que por alguma razão o gravador de DVD's não está a funcionar correctamente quando ligado em simultâneo com o gravador de CD's.
     

Partilhar esta Página