1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Problemas com o site

Discussão em 'Web Development' iniciada por Velshed, 16 de Fevereiro de 2008. (Respostas: 9; Visualizações: 930)

  1. Velshed

    Velshed Power Member

    Boas,
    Tenho um site em flash já alojado. Tem um som de fundo e como tal, coloquei dois botões: um stop e um play. Ao início estava tudo normal mas agora não. Quando se acessa ao site o som toca normalmente, mas quando carregamos no botão stop ele começa a tocar a mesma música por cima, e quando se carrega no play ele pára as duas. Não sei o que se passa, mas eu não mexi nessa parte.
    Outra situaçõ que acontece é a seguinte: eu pus um pre-loader no site e nesse pre-loader está um botão de nome stop intro, que e para passar logo par o site. No entanto esse botão não encontra a página.

    Caso queiram ver o problema o site é o seguinte: (slbenficaolhao.com)

    Cumps
     
  2. Ice-power

    Ice-power Power Member

    para ser sincero, sou do benfica e esse site está demasiado pequeno...mas consigo ler...sim vi o problema...faz ca um sound mesmo á brasil no carnaval se derem ai umas tres vexes xD...bem...

    1º: Deves aumentar o tamanho da página
    2º: Talvez tenhas-te enganado nos codigos
    :Pode haver um hacker, ou então um spyware instalado no teu PC, roubaram-te a pass e estragaram o site(foi os sportiguintas...eu sei!!!)
     
  3. RPortela

    RPortela Power Member

    Boas,

    concordo que possivelmente trocaste os códigos, é a única explicação lógica, é algo que acontece a todos.

    No site reparei num pormenor, sempre que se carrega no "play" e ele começa a tocar uma nova música, a animação relativa ao kit de sócio (penso eu, não sou adepto do benfica :P) a animação recomeça, sempre que se carrega no play.

    Uma sugestão: Aumenta o tamanho do site ;)
     
  4. Velshed

    Velshed Power Member

    Como faço para aumentar o tamanho do site?
    Aumentar como? Em comprimento ou em largura?
    É que eu vejo os outros sites e apresentam uma barra vertical que eu gostava que também aparecesse mas não se como se faz. Alguem explica?

    Eu já tive a ver os códigos e tá td em ordem...
     
  5. Santo38

    Santo38 Power Member

    O botao "Skip" esta a apontar para o ficheiro http://slbenficaolhao.com/c-b-o.html <- Este ficheiro existe? Parece que não pois o nome do ficheiro parece ser http://slbenficaolhao.com/cbo.html . Muda lá o código como deve ser que resolve o problema.

    Tens os códigos dos botões todo trocado. O STOP faz play e mais play e mais play. O start faz STOP e PLAY.

    Se queres mais ajuda posta aqui o código fonte, doutra forma é impossivel ajudar-te

    Saudações
     
  6. Velshed

    Velshed Power Member

    Quanto ao botão skip intro, o código é este:
    on (release) {
    getURL ("cbo.html", "_self");
    }


    Quanto ao botão stop, o código é este:
    on (release) {
    tellTarget ("_root.som") {
    nextFrame ();
    }
    }

    on (release) {
    prevFrame ();
    }




    Quanto ao botão play, o código é este:
    on (release) {
    tellTarget ("_root.som") {
    nextFrame ();
    }
    }
    on (release) {
    nextFrame ();
    }


    Tenho o som num clip que se chama som.

    Cumps
     
  7. michael c

    michael c Power Member

    Queres um conselho? Refaz a parte toda do som. Diz-me só uma coisa, como estás a trabalhar nisso? Por labels? O som no flash é problemático. Por vezes para contrloar o som de uma forma complexa é preciso mesmo muito actionscript.

    No teu caso isso não acontece. Uma vez que o som que toca é sempre o mesmo em todas as secções do site precisas apenas de um player muito simples em que praticamente não usas actionscript e garanto-te por experiência própria que funciona.

    Para te poder ajudar preciso apenas de saber como estás a trabalhar em geral nesse trabalho, se por labels, se por scenes.

    Quanto à intro estás a partir de um principio errado. Ela deveria estar interna ao flash e não num html à parte. Deveria ser chamada com um loadmovie para dentro do swf principal e o skip deveria remeter para um label ou frame interno. Algo deste género:

    on (release) {
    gotoAndPlay ("home");
    }

    Cumps
     
    Última edição: 20 de Fevereiro de 2008
  8. Santo38

    Santo38 Power Member

    Tens algo errado no teu código. Ao clicar o botão Skip não te envia para onde dizes mas sim para outro file. Procura no teu código que deve lá andar alguma coisa sobre esse file.

    A sugestão do Gatekeeper faz sentido sem dúvida.

    Saudações
     
  9. Velshed

    Velshed Power Member

    Eu quanto ao som fui ao google e pus flash tutoriais. O primeiro que aparece cliquei e dps tem la a ensinar como se mete o som. Eu fiz como esta la. O ficheiro som é um movie que é chamado ao clicar nesses botões.
     
  10. michael c

    michael c Power Member


    [​IMG]



    Cá tens a tua solução. Um player simples e eficaz, de acordo com aquilo que pretendes. Na primeiro keyframe de som tens "start" no segundo "stop".

    Quando está na posição on e pressionas ele vai para a posição "off" e vice-versa. Neste exemplo foi usado um vector com animação+um empty button, mas um simples botão a dizer, por exemplo, "Ligar Som" (que estará na posição off) e e outro a dizer "Desligar Som" (que estará na posição on) serve perfeitamente.

    Cumps
     

Partilhar esta Página