1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Problemas com RAID 5 e som

Discussão em 'Dúvidas e Suporte Técnico PC' iniciada por Subversiv0, 17 de Janeiro de 2006. (Respostas: 10; Visualizações: 640)

  1. Subversiv0

    Subversiv0 Power Member

    Boas,

    comprei recentemente uma Sound Blaster XFi Elite Pro.

    Instalei a placa de som e software no computador, e tudo pareceu funcionar perfeitamente.

    O problema é quando activo o RAID 5 do chipset onboard SILICON 3114, este causa interferência na placa de som. E reparem, é mesmo SÓ quando ACTIVO o RAID 5. Os discos podem estar os 3 ligados à board sem problemas, quando crio o Raid Set... o som fica com intereferências.

    A motherboard é uma DFI SLI-DR Expert.

    Os discos que estou a utilizar são SATA Hitachi Deskstar 400Gb (3x).

    Já mudei a placa de som de slot PCI, não resolveu.

    Procurei isolar os discos dos restantes componentes em termos de alimentação power, não resolveu.

    Isolei por último os cabos sata com um material antiestático e não resolveu.

    Alguém já teve um problema semelhante?

    Dêem dicas, mesmo que vos pareçam estúpidas!

    1 abraço ,

    sub
     
  2. Madril

    Madril 1st Folding then Sex

    Tens a ultima bios da board por exemplo ?

    Drivers todos actualizados ?
     
  3. Subversiv0

    Subversiv0 Power Member

    Vou actualizar a bios da board agora mesmo.

    Actualizei os drivers do controlador pelo site DFI, mas não resolveu.

    Vou instalar agora os drivers da Silicon.

    Grato pela resposta pronta Madril ;)
     
  4. Subversiv0

    Subversiv0 Power Member

    Bom... de nada adiantou. :(

    A bios estava actualizada, os drivers também.

    O problema persiste portanto.

    Reparei que o Windows XP atribui o mesmo IRQ à placa de som e ao Silicon 3114. Não sei se é possível mudar o IRQ, isso poderia resolver o problema.

    Alguém sabe como mudar o irq?


    Grato pela ajuda,

    sub
     
  5. Madril

    Madril 1st Folding then Sex

    Ve se no boot o IRQ tb é o mesmo ... e ve se na bios na tem nada pra mudar isso.
     
  6. MonkSP

    MonkSP Power Member

    Eu tenho um rpblema pareceido e nunca o consegui resolver. cada vez que os discos estão a funcionar (sejam IDE, sejam SATA RAID 0) o som que sai no painel frontal da caixa fica com ineterências. Já troquei discos e troquei de oscultadores e nunca resolveu. Claro que também meti drivers diferentes...e mesmo assim nada
     
  7. gatohumano

    gatohumano I'm cool cuz I Fold

    como são esses ruidos?pode ser interferencia eletromagnetica ou entao algum conflito maluco,experimentem o seguinte,baixem todos os controlos de volume excepto o wave e o principal,se deixar de fazer ruido entao o problema pode estar nalguma das entradas,vejam os cabos que ligam as saida de audio do cdrom,se o cabo estiver ligado a massa nas 2 pontas esperimentem cortar o cabo da massa da ficha numa das 2 pontas,tb pode ser outras coisas mas ja mais complicado.
     
  8. MonkSP

    MonkSP Power Member

    Já testei e continua a fazer ruídos mesmo quando não à som nenhum wave. Não tenho sequer ligados os cabos de audio do CDrom. Isto acontece esteja a houvir mp3, esteja a jogar.
     
  9. Subversiv0

    Subversiv0 Power Member

    OI!

    pelo que me apercebo este é um problema que afecta bastante gente.

    Não sei se a causa do MonkSP será a mesma que a minha...

    Quando tenho o silicon sata 3114 desligado (desactivado no gestor de dispositivos) tudo funciona perfeitamente, o som é cristalino (literalmente). Quando activo o Silicon 3114 (controlador RAID onboard, tenho 3 discos em Raid 5)... o som é cheio de ruído, mal se percebe, como um rádio mal sintonizado.

    Não creio que adiantasse de muito a tua solução gato humano, de qualquer forma obrigado! :)

    Presumo que efectivamente seja uma questão de IRQ´s.

    Quando o comp faz boot é atribuído ao Silicon o IRQ 5, o mesmo que é atribuído à placa de som (estranhamente, ao mudar de slot não lhe é atribuído um novo IRQ, algo que em teoria devia acontecer).

    O Windows XP atribui aos 2 o irq 16. Ora... não é possível mudar isto (pelo menos a julgar pelo que a Microsoft diz). A gestão dos recursos do comp é feita pelo ACPI automaticamente.

    Solução: Instalar o Windows sem o maravilhoso ACPI (requer nova instalação). Ao que parece tem de se desactivar a opção na bios e em seguida instalar o windows de novo.

    A minha board em particular não me permite reservar um IRQ a uma porta PCI em particular, isto poderia resolver o problema.

    Não se trata de um problema de interferência, porque se assim fosse a intereferência devia verificar-se mesmo com o raid 5 do silicon 3114 desligado.

    Parece mais ser um bottleneck.

    Monk, podes experimentar 2 coisas que comigo resultaram para retirar algum ruído da minha anterior placa (audigy 4 pro, basicamente uma audigy 2 de cara lavada):

    no dxdiag corta a aceleração por hardware, selecciona a opção "sem aceleração". Isso resolvia-me um problema chato de ruídos no Half Life 2 (start-->run-->dxdiag, procura a bracket som/sound).

    Outra coisa é... mudar o slot PCI onde tens a placa de som, afasta-a o mais possível dos outros componentes (para reduzir o risco de interferência).

    Nenhuma das soluções funcionou no meu caso, no entanto não quer dizer que nunca funcione.

    Mais uma vez, obrigado!

    Sub
     
  10. MonkSP

    MonkSP Power Member

    Boas subversivo! Afinal li mal o teu post. Eu tenho problema identico ao teu mas o hardware é diferente. Não tenho a place de som externa mas sim uso o modulo da NF4. De resto os sintomas são os mesmos.
    Vou testar isso do ACPI mas acho esquisito porque tinha o mesmo problema com os discos IDE.
     
  11. Subversiv0

    Subversiv0 Power Member

    Boas Monk,

    já agora posta aqui os resultados :P

    Acabei por abandonar o raid 5... é que ainda por cima são 3 discos de 400 GB... optei por ter 2 em raid 1 e ter o outro disponível... para guardar coisas sem grande importância.

    Mas se isso do ACPI funcionar...

    Este fim de semana pode ser que me dê na cabeça, pegue num disco e experimente.

    Abraço,

    sub
     

Partilhar esta Página