1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Razer Deathadder

Discussão em 'Dúvidas e Suporte Técnico - GNU/Linux & *nix' iniciada por IntuitioN, 4 de Junho de 2009. (Respostas: 8; Visualizações: 1381)

  1. IntuitioN

    IntuitioN Power Member

    Boas.

    Gostaria de pedir que alguém me desse umas luzes em relação a como instalar o rato razer Deathadder no ubuntu 9.04 sff. os botões de lado, back and foward não funcionam, bem como a wheel, e obviamente não tenho controlo sobre os dpis.

    Após algumas pesquisas o melhor que encontrei foi:

    http://bu3sch.de/joomla/index.php/razer-nextgen-config-tool

    que apesar de, aparentemente não me instalar os botões, apenas configurar os dpis, foi o que experimentei.





    Segui os passos até

    "Please reboot the machine or enter the following command to activate the
    udev notification:

    udevadm control --reload_rules",

    que não resultou ("udevadm control expects commands without underscore, this will stop working in a future release"); sem underscore não era reconhecido.


    A partir daí, o "readme" lista mais três comandos, supostamente já para abrir o programa, mas obtenho os seguintes erros:




    razerd: error while loading shared libraries: librazer.so: cannot open shared object file: No such file or directory

    Failed to connect to razerd socket: [Errno 2] No such file or directory

    Traceback (most recent call last):
    File "/usr/local/bin/qrazercfg", line 18, in <module>
    from PyQt4.QtCore import *
    ImportError: No module named PyQt4.QtCore


    Não faço ideia de como continuar. Seja em resolução destes erros ou com algum outro tipo de tutorial/programa, agradecia alguma ajuda a configurar o rato:) Ninguém por aqui a usar deathadders no ubuntu?

    ps.: As funcionalidades dos botões são prioritárias em relação às funcionalidades extra (alterar DPIs etc),
    Nota.: Eu sei muito pouco ou nada de linux.. se não fosse inconveniente, era bom especificar o que seria "óbvio" sff :p



    Obrigado pela atenção,
    IntuitioN
     
  2. armagedalbeebop

    armagedalbeebop Power Member

    se calhar nao tens o pyqt,mas nao sei realmente se é isso
     
  3. DarkVenger

    DarkVenger Power Member

    Se no teu /etc/X11/xorg.conf existir a linha
    Código:
    Option "AutoAddDevices" "False"
    significa que não estarás a usar o HAL e como tal deverás ter, neste mesmo ficheiro, uma secção que configura o rato tipo (comentei algumas das linhas para tentar que percebas melhor)
    Código:
    Section "InputDevice"
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "ExplorerPS/2" #Um dos protocolos maravilha
        Option         "Device" "/dev/psaux" #Truque para parecer q se tem hotpluging
        Option	   "Buttons" "7" #Numero de botões do rato, atenção q cada direcção da wheel é um botão
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5" #Faz com que a wheel faça scroll
        Option	   "HWHEELRelativeAxisButtons" "6 7" #Habilita scroll horizontal
        Option	   "ButtonMapping" "1 2 3 4 5 7 6" #Define o mapeamento físico dos botões, neste caso em particular troco o 6 e o 7 para que o meu scroll horizontal funcione como quero.
    EndSection
    Só a troca de protocolo já te deve alterar o comportamento do rato, para todas as opções do driver consulta isto (Por exemplo a opção Resolution parece-me definir os dpis). Para saberes qual o botão que o sistema interpreta quando carregas no rato, abre um terminal no x e escreve xev aparece-te uma pequena janela, dentro dela clicka com cada um dos botões, procurando não mexer no rato e no terminal aparece-te algo do género, (carreguei no 3º botão, q é o do lado direito)
    Código:
    ButtonRelease event, serial 31, synthetic NO, window 0x3400001,
        root 0x1a7, subw 0x0, time 1825448, (64,76), root:(906,401),
        state 0x400, [B]button 3[/B], same_screen YES
    
    Caso não tenhas a tal linha que disse logo de início estás a usar o HAL e dado que este ainda não tem uma boa forma para configurar tens de criar um ficheiro xml à mão. E a partir daqui não te dou certezas porque nunca o fiz para o rato, mas já fiz para o touchpad por exemplo.
    Este ficheiro cria-se dentro da pasta /etc/hal/fdi/policy e podes copiar um para começares a editar de/usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi
    A parte que te interessa é colocar opções a partir da linha 15, como por exemplo, (a 2ª linha já é o exemplo)
    Código:
    <merge key="input.x11_driver" type="string">evdev</merge>
    <merge key="input.x11_options.Protocol" type="string">ExplorerPS/2</merge>
    as opções serão todas as indicadas no link que já dei.

    Boa sorte e espero não ter confundido mais ainda :p
     
  4. IntuitioN

    IntuitioN Power Member

    A tal linha não existia no ficheiro (Nem nenhuma outra com parâmetro "AutoAddDevices", outro valor);

    portanto fui editar o ficheiro em /etc/hal/fdi/policy como sugerido. acontece que, definindo resoluções diferentes,

    <merge key="input.x11_options.Resolution" type="integer">1200</merge>
    ou
    <merge key="input.x11_options.Resolution" type="integer">200</merge>

    (e gravar com sucesso obviamente), não havia diferença rigorosamente nenhuma na resolução, e o rato em questão suporta até aos 1800 DPIs.



    O meu ficheiro preferences.fdi em /etc/hal/fdi/policy/ é, agora, o seguinte (sendo que eu apenas adicionei as linhas 28 a 31).
    (Não será preciso fazer um comando que faça algo do estilo "oi? está ali aquele ficheiro de configuração. Usa-o!" ?)
    Código:
    <?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->
    
    <!-- 
      Some examples how to use hal fdi files for system preferences 
      You can either uncomment the examples here or put them in a seperate .fdi
      file.
    -->
    <deviceinfo version="0.2">
    <!-- 
      The following shows how to hint gnome-volume-manager and other programs 
      that honor the storage.automount_enabled_hint to not mount non-removable
      media.
    -->
    
      <device>
        <match key="storage.hotpluggable" bool="false">
          <match key="storage.removable" bool="false">
            <merge key="storage.automount_enabled_hint" type="bool">false</merge>
          </match>
        </match>
    
        <!-- FIXME: Support tablets too. -->
        <match key="info.capabilities" contains="input.mouse">
          <merge key="input.x11_driver" type="string">mouse</merge>
          <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
                 string="Linux">
            <merge key="input.x11_driver" type="string">evdev</merge>
        <merge key="input.x11_options.Protocol" type="string">USB</merge>
        <merge key="input.x11_options.Device" type="string">"/dev/mouse"</merge>
        <merge key="input.x11_options.Buttons" type="integer">9</merge>
        <merge key="input.x11_options.Resolution" type="integer">1200</merge>
          </match>
        </match>
    
      </device>
    
    
    </deviceinfo>


    Fora isso, considerando que a resolução funcionasse, não estaria a ver como definir o comportamento das teclas laterais, apesar de saber o código do botão graças ao comando "xev".


    (Já agora, afinal a wheel funciona, não sei porque é que tinha a ideia que não funcionava, talvez quando me surgiu isso na mente estivesse nalguma aplicação em particular na qual não funcionasse, não sei.)

    Nota: No /etc/X11/xorg.conf também não tenho nenhum bloco de texto
    Section "InputDevice",
    suponho que seja normal não tendo a linha
    Option "AutoAddDevices" "False", estou apenas a dizer caso possa ser irregular. :S
     
    Última edição: 5 de Junho de 2009
  5. DarkVenger

    DarkVenger Power Member

    Confirmo, tens de reiniciar o hal (/etc/rc.d/hal restart) ou então reiniciar mesmo o PC. Teoricamente, creio q também funcionava tirar o rato e voltar a ligar.

    Humm, para dares um comportamento específico às referidas teclas acho que tem de ser no próprio GNOME, haverá um sítio para isso nas preferências. Caso não haja terás de usar o imwheel e ter alguma paciência com o xmodmap (ou talvez não se tudo de correr bem à primeira ;) ). Links de interesse UbuntuCommunity e UbuntuForum

    Com o HAL é normalíssimo, o xorg.conf quase só serve para configurar a gráfica. Espera-se que o HAL passe a tratar disso igualmente de futuro.

    Boa sorte :D
     
  6. IntuitioN

    IntuitioN Power Member

    Obrigado por tentarem ajudar, vim só dizer que vou esquecer o linux por enquanto, porque isto foi um pouco frustrante.


    Após tentar fazer o sugerido .. (já agora: /etc/rc.d/hal restart dava-me "hal: unknown command"), e não conseguir, tentei pesquisar mais, segui para ali tutoriais que mexiam num tal "imwheel" que tive de instalar e fazer uns "xmodmap" qualquer coisa.. enfim, não sei o que fiz mas acho que não mexi em gráficos.
    Finalmente dizia para reiniciar o X server, perguntei no irc como se fazia, parece que no ubuntu 9.04 é preciso instalar um ... hmm.. "dontzap" ou algo assim.

    Prontos já que fui tão longe vá de instalar dontzap. reiniciar X server reinicia ... not. fica o S.O. bloqueado com imagem defeituosa... claramente que os gráficos estavam lixados ou.. algo assim. E prontos agora iniciar é mentira. Talvez em modo de recuperação dê mas não experimentei porque se entrar lá não sei o que fazer daquilo, xD

    Foi só para contar a experiência inédita, "O gajo que lixou o linux ao tentar meter dois botões do rato a funcionar". Por agora, i'll stick to windows. >.<

    Mais uma vez, obrigado por tentarem ajudar :P
     
  7. DarkVenger

    DarkVenger Power Member

    Instalar o dontzap? O que era necessário era acrescentar ao xorg.conf o seguinte
    E depois pressionar a combinação CTRL+ALT+BACKSPACE.

    Quanto ao xmodmap eu bem disse que era preciso paciência :p, aquilo até a mim me baralha...
    O HAL talvez em Ubuntu, o restart, seja feito de outra forma :confused: q não sei dado não o usar.


    Enfim, é pena que abandones assim o Linux mas pode ser que ainda voltes ;). No entanto entendo-te a frustração.
     
  8. armagedalbeebop

    armagedalbeebop Power Member

    ubuntu usa agora o rc.d? tinha noção que era outro,

    edit: é no init.d ..isto se nao mudou
     
    Última edição: 6 de Junho de 2009
  9. IntuitioN

    IntuitioN Power Member

    Heh, ya ainda hei-de voltar. Enfim, tentar.

    Esta já foi a segunda ou terceira tentativa. É um pouco chato o ubuntu que parece ser a mais user-friendly das distribuições de linux não venha configurada para reconhecer algumas das coisas simples (botões do rato xD)

    Foi azar.. :(
     

Partilhar esta Página