1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Streaming video muito lento...

Discussão em 'Dúvidas e Suporte—Internet, Redes, Segurança' iniciada por gleal2000, 19 de Novembro de 2007. (Respostas: 14; Visualizações: 4779)

  1. gleal2000

    gleal2000 Power Member

    Boa noite

    Montei uma rede wireless doméstica e apesar de algumas dificuldades lá meti isto a funcionar a meio gás.

    Tenho internet partilhada, consigo ver os pcs na rede e partilhar ficheiros, mas se tentar fazer abrir um filme a partir de outro pc a janela do explorer bloqueia, o video demora uma eternidade a abrir e depois faz-se aos soluços e com muitas quebras.
    A internet é rápida, e a rede penso que tb, demoro 10 minutos a copiar um filme de 700mb pela rede, logo não devia ter problemas com video streaming, certo?

    Tenho um Linksys wag200g ligado por cabo ao um pc e wireless a outro pc na divisão ao lado com uma placa de rede asus, segundo o software da asus o sinal está sempre "excelent" e a 54mbps.

    Tenho tb firewall da Sygate nos 2 pcs com as devidas permissões.

    Sugestões?
    Obrigado desde já :)
     
    Última edição: 30 de Novembro de 2007
  2. gleal2000

    gleal2000 Power Member

    ninguém?? :(

    outro teste que fiz, foi desligar firewall e antivirus e é igual.
    outra coisa estranha é que fizer isto ao contrário, no outro pc (abrir um filme no escritório que está no disco do htpc) já funciona bem!

    os pcs são os da assinatura e aqui ao lado.
     
  3. Mega

    Mega Power Member

    Epa, não te sei ajudar... Tens placa de tv em algum deles? tenho curiosidade em saber se fizeres strem de um pc com a placa de tv consegues ver no outro...
     
  4. gleal2000

    gleal2000 Power Member

    não tenho placa de tv.
     
  5. FutureNeo

    FutureNeo Power Member

    Não confundir Internet com Ethernet. A Internet está fora da tua rede. A tua velocidade interna da rede não tem de ser obrigatoriamente a mesma que a do exterior (além disso o teu download podes ser superior ao teu upload, ai e se estivesses a fazer streaming, iria afectar a transmissão...). Alem disso, o facto de copiares um filme em 10 minutos não quer dizer que possas copiar todos os filmes em 10m (vai depender do tipo de ficheiro e da forma de compressão usada, do trafego da rede por exemplo). Quanto a streaming...não sei bem se o que tu fazes é streaming. O que tu pretendes é poder abrir um filme que está no PC 1 e vê-lo no PC2, certo? Ora para isso não tens de fazer streaming (penso eu e se estiver errado corrijam-me...). Apenas tens de internamente aceder ao ficheiro e abri-lo no PC que pretendes. este será executado como se estivesse nesse disco. Portanto o problema deverá ser outro. Talvez as configurações da ligação (incluindo as configurações do router) ou alguma interferência (tendo em conta que colocaste de parte a firewall e anti-virus).
    Se alguém tiver outras ideias ou se quiser corrijir algo do que disse estejam à vontade!
    Boa Sorte!

    (Ops!vendo melhor acho que realmente fazes "streaming"...)
     
    Última edição: 29 de Novembro de 2007
  6. gleal2000

    gleal2000 Power Member

    sim realmente da maneira que estava a frase, parecia que estava meter a internet ao barulho, mas não, já editei.
    não sei se a expressão streaming é correcta, mas é isso mesmo, quero ver no pc da sala um filme que está no disco do pc do escritório sem ter que o copiar primeiro.
    como hei-de diagnosticar o problema? será da velocidade da rede wireless que não aguenta? sera a placa de rede wireless que é rasca? sera o pc que não aguenta o processo todo?

    quando tiver oportunidade hei-de trazer cá um colega com um portátil para testar a rede porque penso mesmo que o problema estará no pc/placa de rede wireless...
     
    Última edição: 30 de Novembro de 2007
  7. snis

    snis Power Member

    epah, eu ligo o porattil da rede (wireless) acedo ao server (ligado por cabo ao router) e , claro q a copiar dados demora , pois a minha placa wireless so é de 11mbps..mesmo assim vejo na boa filmes , que estao no servidor, pela rede
     
  8. snis

    snis Power Member

    epah, eu ligo o porattil da rede (wireless) acedo ao server (ligado por cabo ao router) e , claro q a copiar dados demora , pois a minha placa wireless so é de 11mbps..mesmo assim vejo na boa filmes , que estão no servidor, pela rede
     
  9. gleal2000

    gleal2000 Power Member

    pois lá está. então o problema está no pc, não é na rede.
     
  10. Anthrax_OC

    Anthrax_OC 1st Folding then Sex

    O filme que estás a tentar ver está em HD (alta definição)? Ou é um DivX normal?

    Eu por exemplo com DivX não tenhp qualquer problema usando a rede wireless, mas se for tentar ver alguma coisa em HD, x264, é para esquecer, tenho alguns breaks e torna-se impossível de ver em condições.

    Não tens mais nada a usar a rede enquanto tentas visualizar o filme, tipo P2P ou assim. Já descartaste a hipótese de teres ai alguma virose ou afim que te roube largura de banda?
     
  11. gleal2000

    gleal2000 Power Member

    é divx, x264 nem directamente do disco dá para vêr em condições.

    tenho o kaspersky actualizado e a fazer um scan todas as semanas, acho que não é disso. será possível a placa de rede ter algum defeito e não consiga uma largura de banda constante? já reparei que enquanto o video está a correr (soluçar), no software da placa de rede, a velocidade baixa e sobe constantemente chegando a baixar até aos 11 Mbps e depois volta a subir até aos 54 mbps, enquanto se não tiver a esforçar a rede (por ex. internet) mantém-se nos 54 mbps.
     
    Última edição: 30 de Novembro de 2007
  12. FutureNeo

    FutureNeo Power Member

    Acontece com qualquer leitor ou com algum especifico (ex: "janelas media player", "real player" ...etc...)?????
     
  13. ShadeX

    ShadeX Power Member

    O problema é precisamente não ser streaming. Mete o VLC a servir no outro PC e um VLC client no teu e já tens streaming.

    O que estás a fazer de momento é "ler bloco, reproduzir bloco, ler bloco, reproduzir bloco" etc... O que isso causa é que o leitor lê um bom bocado do filme até encher o cache e depois reproduz. Se for por exemplo DivX, basta ler 10MB e já tens uns bons segundos (minuto?) de filme. Ora, pela altura que ele pedir mais info tem de parar, ir buscar mais, recomeçar.

    Como o player (90% deles...) pensa que o ficheiro é local, assume (erradamente) que não tem de fazer preemptive caching, ie, ler mais antes de acabar a info.

    Em streaming a info é passada primeiro em bloco para encher um cache e depois pouco a pouco para manter o cache cheio. Como a ligação não quebra e a passagem de info é mais ou menos constante, não tens essa quebras que basicamente derivam de um player que pensa que o ficheiro é local e um filesystem que é remoto.

    Qqr modo, experimenta outro layer (Media Player Classic, VLC, etc...) pq o comportamento varia de uns para outros. Se a box remota tiver CPU power que chegue podes mesmo montar o VLC como streaming server e pronto, acaba-se a bronquite.
     
  14. gleal2000

    gleal2000 Power Member

    obrigado pelas respostas :)

    o problema mantém-se com qualquer player, wmc, mpc, vlc, nero mp, vlc...
    para fazer de streaming server, tenho que selecionar primeiro o filme que quero ver no pc remoto, certo?
     
  15. ShadeX

    ShadeX Power Member

    Boa pergunta. Nunca usei essa parte do VLC, mas deve ter docs exaustivos para não variar muito...
     

Partilhar esta Página