1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Ubunto/XP: Os ficheiros desaparecidos!!

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por van_Zeller, 10 de Abril de 2007. (Respostas: 9; Visualizações: 1066)

  1. van_Zeller

    van_Zeller Power Member

    Boas pessoal

    Tenho um PC com um disco com XP e Linux com 3 partições, 2 para os sistemas operativos e 1 para os documentos. A partição dos documentos está em NTFS e eu tenho acesso de leitura e escrita nessa partição. Até aqui tudo bem.
    O mistério começa quando eu notei que certas pastas não têm lá dentro tudo o que deviam, ou seja, há ficheiros mp3 que eu só consigo aceder pelo XP. No total, a minha discoteca devia ser composta por 3500+ musicas, mas no Ubunto, só aparecem ~3400. Todas as 3500+ funcionam perfeitamente no XP! O album dos da weasel, por exemplo só tem 4 musicas no Ubunto, mas aparece completo e funciona perfeitamente no XP!

    Já desfragmentei o disco e já corri o scandisk do windows. De resto, tenho o PC a funcionar perfeitamente.

    Ideias?
     
  2. astrisko

    astrisko 1st Folding then Sex

    Isso deve ser por causa da codificação dos caracteres ser UTF-8, para a mudar tens que editar o
    /etc/fstab na linha "locale=en_US.utf8", escreves "locale=en_US.ISO-8859-1".

    Atenção que não tenho a certeza, mas pela lógica deve ser assim.
     
  3. van_Zeller

    van_Zeller Power Member

    Tens um faro mto apurado, porque eu mudei alguns nomes de musicas para coisas tipo ãéíõ e assim e de facto desapareceram!
    A má notícia é que não consigo editar o fstab como deve ser, devo estar a fazer alguma coisa mal...Tenho a linha em questão assim:

    /dev/sda3 /media/DOCUMENTS ntfs-3g defaults,locale=en_US.ISO-8859-1 0 0

    Podes-me explicar exactamente qual o aspecto que o fstab devia ter?
     
  4. tmafcerqueira

    tmafcerqueira Power Member

    Este é o meu fstab. Se puseres as tuas partiçoes windows como eu tenho as minhas duas ultimas linhas (o /dev/sda6 e o /dev/hda1) nao deves ter problemas... Obviamente, muda o path dos dispositvos:007:
    Fica bem;)
    Código:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    /dev/sda2       /               ext3    defaults,errors=remount-ro 0       1
    /dev/sda5       /home           ext3    defaults        0       2
    /dev/sda1       none            swap    sw              0       0
    /dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0
    /dev/hdd        /media/cdrom1   udf,iso9660 user,noauto     0       0
    /dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
    /dev/sda6    /media/f    ntfs-3g umask=0,nls=utf8,locale=pt_PT.utf8     0    0
    /dev/hda1    /media/c     ntfs-3g umask=0,nls=utf8,locale=pt_PT.utf8     0     0
    
     
  5. van_Zeller

    van_Zeller Power Member

    Fiz o que disseste, mas mesmo assim, não consigo fazer com que apareçam as musicas dos da weasel cujo nome tem caracteres portugueses (ãééĩ etc)...O meu fstab tem este aspecto(não ligues à confusão):
    Código:
    
    # /etc/fstab: static file system information.b
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # /dev/sda4
    UUID=4d30f8c4-7148-41cc-9b47-b1e242b1fe41 /               ext3    defaults,errors=remount-ro 0       1
    # /dev/sda2
    #UUID=FCEC21A3EC2158E2 /media/sda2     ntfs    defaults,nls=utf8,umask=007,gid=46 0       1
    # /dev/sda1
    UUID=3af827dd-b9b0-4801-89dc-94da55c72227 none            swap    sw              0       0
    /dev/hda    /media/cdrom0      udf,iso9660 user,noauto     0       0
    /dev/       /media/floppy0     auto        rw,user,noauto  0       0
    /dev/sda3   /media/DOCUMENTS  ntfs-3g     umask=0,nls=utf8,locale=pt_PT.utf8     0    0
    #/dev/sdb1   /media/B-UP        ntfs-3g     defaults,locale=en_US.ISO-8859-1   0    0
    Alguma ideia?

    EDIT - Mais detalhes:

    [​IMG]
     
    Última edição: 10 de Abril de 2007
  6. van_Zeller

    van_Zeller Power Member

    Se dúvidas houvesse, esta imagem esclarece:

    [​IMG]

    Está visto que é um problema de caracteres especiais. Portanto agora a pergunta que se impõe agora é:

    Como é que eu faço o Ubuntu suportar nomes de ficheiros com caracteres especiais em discos NTFS??

    Help!!
     
  7. van_Zeller

    van_Zeller Power Member

    Ok, estive a ver aqui:

    http://www.guiaubuntupt.org/wiki/in...eitura_e_escrita_ntfs-3g#Configurar_o_NTFS-3G

    e li o seguinte:

    Ora aparentemente, vendo o meu ficheiro "local", constato o seguinte:

    Não suporta português. E agora?
     
  8. tmafcerqueira

    tmafcerqueira Power Member

    Primeiro vais a /etc e fazes:
    cp -p locale.gen locale.gen_backup
    depois fazes sudo gedit locale.gen e mudas o en_US.UTF-8 UTF-8 para pt_PT.UTF-8 UTF-8
    Depois escreves sudo /usr/sbin/locale-gen
    Fica bem;)
     
    Última edição: 15 de Abril de 2007
  9. tmafcerqueira

    tmafcerqueira Power Member

    Ja agora, é possivel ter 2 locales? É que ha programas que nao suportam o pt_pt, e nao dao erro, mas aparecem umas linhas maradas no apt-get, e se houver problemas é mais dificil diagnosticar...
     

Partilhar esta Página